Peugeot Forums banner

1 - 20 of 56 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1 (Edited)
Hi all just bought the missus a 308 1.6 hdi ( 90 ) off my dads next door neighbour. It has always been a bad started for him, he had it at a garage who checked the injectors and fuel pressure sensor, all ok, changed the fuel filter and still struggled to start when cold, but once warmed up would start ok. apparantly they changed the tank and it started straight away just to test it.

He got it back from the garage and it has been parked up since ( about 4-5 months ) due to him having a work car.

I went over today knowing the battery would be flat so took over my spare bosch s4 battery, only a few month old so know its good. tried to prime the bulb then start it but wont fire, will turn over though. Even tried it with easy start, will run on easy start but soon as I stop spraying it dies. the rev counter stops working after a few seconds and nothing is on the display at this point.

When you first get it and turn the ignition on it says economy mode active on the display, then the display goes off after about 10-15 seconds, there is a an exclimation mark inside a triangle on clocks and the eml is on.

I'm thinking the car has forgot the keys or something with battery being flat for so long as central locking wont work either with remote or key in the lock. The electric windows wont go up or down either

Anyone got any ideas?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
no mate how would you do that?

I seen one on google saying window needs to be down for it and mine wont go down
 

·
Registered
Joined
·
40 Posts
You sure the battery is sufficiently charged, if economy mode comes on that quickly it suggests perhaps it's not

Sent from my D6503 using Tapatalk
 

·
Registered
Joined
·
40 Posts
And yes, the window needs to be down, I'm on my phone ATM, but there is a pretty good sticky on the forum somewhere detailing how to perform a BSI reset it you hunt around (in the technical section iirc)

Sent from my D6503 using Tapatalk
 

·
Registered
Joined
·
60 Posts
Discussion Starter #6
Yeah thats the one I seen, cheers.

since the window wont come down guess I'll have to try it tomorrow when my dad is here so I can sit in car and he can disconnect and reconnect battery for me
 

·
Registered
Joined
·
60 Posts
Discussion Starter #8
After trying to start turn off leave key in and open drivers door, does it beep to say key is still in

Cheers mate I'll have to try this tomorrow as car is still over at mam and dad's and I'm at home with kids now.


From what I can remember it didn't beep to say key was in. Would that be a bad thing?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #9
After trying to start turn off leave key in and open drivers door, does it beep to say key is still in
Hi mate just a update, I got it out of economy mode now, Windows go down now and radio works but it doesn't beep when I turn ignition off and leave key in when opening the door. Remote central locking isn't working either so guess it's related.

Went to try the batter out of my 307 but they are different sizes. Since there's no immobilizer chip in these keys take they need a working battery in there?
 

·
Moderator
Joined
·
5,071 Posts
Sounds like bsi has lost it settings. Does the wipers lights and indicators work
That doesn't sound good ?

Sent from my K013 using Tapatalk
 

·
Registered
Joined
·
60 Posts
Discussion Starter #12
Didn't try the wipers or indicators mate, but did try the side lights when I reset bsi by the disconnecting battery for 3 mins method and they worked, windows also went down.

I noticed when it was running on easy start and if a nut cracked off on a injector there was fuel squirting out, but if it was just cranking on its own there was none comiong out, like the pump isn't sucking enough or something, if the car has forgot it's key would this stop the pump sucking on the key as I thought it would just stop the injectors firing?

Trem kindly let me borrow his PP and tried connecting it to the car but kept getting " impossibile to read " something error, however by this point the car was back into ecomomy mode due to flat battery so I have brought battery home to charge and will try again tomorrow.

Tomorrow I'm thinking I might get some clear fuel pipe and put them straight from the tank to the primer bulb so I can see what is happening with the fuel
 

·
Registered
Joined
·
60 Posts
Discussion Starter #13
hi all, indicators work, lights work, boot works, central locking works but only with the key from the passenger door. when ignition is on and on and out of economy mode it says anti-theft sytem fault on the display screen, also still not beeping when I open the door and leave key in the ignition.

Looked at the BSI with PP2000 and it had the folloing error Transponder ( without hands free starting ) or badge ( with hands free starting ) recognition fault. Not characterised. Local. Also in the ECU's present for BSI it says old generation or transrange. Is this normal?
 

·
Registered
Joined
·
15,377 Posts
No beep no start its a well documented thing on here you need to recode the keys stop opening fuel lines its not a fuel problem its a key problem the key is not coded to the immobiliser due to someone with too little knowledge disconnecting battery too quick or with ignition on or the battery going flat or some other ELECTRICAL problem.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #16
Sounds like it's lost the key transponder information and needs to have the keys reprogrammed with PP2000

Would I need the pin code thing to do that mate? If so would I need the logbook to get one as the previous owner has lost everything for it, so waiting on new logbook coming back
 

·
Registered
Joined
·
60 Posts
Discussion Starter #17
No beep no start its a well documented thing on here you need to recode the keys stop opening fuel lines its not a fuel problem its a key problem the key is not coded to the immobiliser due to someone with too little knowledge disconnecting battery too quick or with ignition on or the battery going flat or some other ELECTRICAL problem.
Yes but would the key needing coded actually stop the pump sucking when just cranking by the key? As I thought that would soley stop the injectors firing
 

·
Registered
Joined
·
60 Posts
Discussion Starter #20
Just an update guys, got my code thanks to trustme, but still not having any luck in programming the key.

Put the code in which says it's correct, goes through all the stuff about how many keys to program then it says you have 15 seconds to turn ignition on, but as soon as I do that it says programming of key failed.

So looks like I'll start with the cheapest thing first of buying a new key, if that still fails, whereabouts is the receiver in the car located?
 
1 - 20 of 56 Posts
Top