Peugeot Forums banner

41 - 60 of 86 Posts

·
Moderator
Joined
·
7,934 Posts
Its the vacuum pipe for doser valve they don't have clips should be a snug fit.

If you have enough slack chop 5-6mm of the top of the hose and it should fit tighter

Sent from my SM-T830 using Tapatalk
 
  • Like
Reactions: madbadandold

·
Registered
Joined
·
97 Posts
Discussion Starter #47
Yes, is there not meant to be? Also,
I've just got an "anti pollution fault" on my dash and engine light on now !!! I think this car is on the way out ☹ Also getting error code of
P2002, P1457 these appeared with the anti pollution warning.
P1352 which I believe is the glow plug relay, which has just been delivered to me but not yet fitted.
 

·
Moderator
Joined
·
7,934 Posts
Those codes both relate to DPF fault maybe a hose off/split or water trapped in it between DPF and sensor (near servo)
 

·
Registered
Joined
·
97 Posts
Discussion Starter #49
The generic reader I've got says
P2002 is "particulate trap bank 1 efficiency below threshold"
P1457 "unable to pull vacuum in tank"

I guess if the new glow plug relay I've still to fit helps the glow plugs then it might stand a chance of a regen? Thus getting rid of all the DPF codes?
Thanks
 

·
Moderator
Joined
·
7,934 Posts
Yes in Peugeot codes that translates to DPF is blocked or punctures and there is no pressure drop across the dpf pressure sensor

Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
97 Posts
Discussion Starter #51
So from that I guess it's
1 - the relay makes the regen happen (long drive revving high, but can't Rev over 2600 as light on!!!)
OR
2 - the DPF is cleaned or replaced
 

·
Registered
Joined
·
97 Posts
Discussion Starter #52
Relay now fitted and I can hear it clicking with ignition lights on as I couldn't with the old on so we can but hope that the glow plugs now work! And it will prompt a regen. Any tips to aid regen?
 

·
Registered
Joined
·
97 Posts
Discussion Starter #53
Trouble starting again this morning!! It took 25 minutes before it actually caught and fired up. Once started though it's perfectly good for the rest of the day????
Any ideas on what else I could do bearing in mind all the things previously talked about. Not sure if I want to put £500 into it or put that money into another car. It's now done 161742 miles, not too bad really I guess
 

·
Premium Member
Joined
·
2,675 Posts
So it looks like the dpf needs further investigation. And the pipe should not have oil in it as it is a vacuum line!
 

·
Registered
Joined
·
97 Posts
Discussion Starter #55
Thanks but I'm not sure if I want to spend time and possibly much money if something else is going to go wrong with it! I've just done a 50 mile motorway trip in 3rd gear at 4K revs at 70mph and the rear screen on and all it has burnt off is 1.5gallon of fuel and no regen! It should have done something surely???
 

·
Registered
Joined
·
97 Posts
Discussion Starter #56
Actually I have just bought some Millers eco max to have a good clear out of fuel lines etc. I'll put in the required dose until it's all gone just to rule out any blocked fuel issues.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #57
Update,
I've put in the required dose of millers eco max and now when I accelerate it's nothing but grey smoke!!! All it's done is p***ed people off that are behind me.
Bloody car!!!! It's gonna die, I just know it, right at the most inconvenient time.
 

·
Moderator
Joined
·
7,934 Posts
Sounds like you have a failing injector this would also explain poor cold starting. Leak off test may be worth doing to identify which injector maybe on the wayout
 

·
Registered
Joined
·
97 Posts
Discussion Starter #60
Thanks for all your help everyone it's much appreciated. If I get it sorted (minimal budget only) I'll post my results. Once again many thanks to all especially windy and mad
 
41 - 60 of 86 Posts
Top