Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi all, I have a 2004 307CC and have a problem with the reverse sensors. I had them checked and was told there is no fault with the sensors, it was down to the aftermarket stereo in the car. I have recently changed this to an original stereo and the sensors still don't work. Do I need to get them activated? Hope this makes sense. Cheers Phil
 

·
Registered
Joined
·
687 Posts
Hi all, I have a 2004 307CC and have a problem with the reverse sensors. I had them checked and was told there is no fault with the sensors, it was down to the aftermarket stereo in the car. I have recently changed this to an original stereo and the sensors still don't work. Do I need to get them activated? Hope this makes sense. Cheers Phil
What kind of problem? Beeping all the time when reversing? Not working? Fault just appeared or have you had it a while?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Not working at all the switch on the dash isn't responding either. My mate has all the tech stuff and he checked the sensors and couldn't find a fault.
All that was wrong was the aftermarket stereo
 

·
Registered
Joined
·
687 Posts
Not working at all the switch on the dash isn't responding either. My mate has all the tech stuff and he checked the sensors and couldn't find a fault.
All that was wrong was the aftermarket stereo
If there is a switch on the dash, I assume they are aftermarket ones as mine come on as soon as the car is put into reverse.

If they are the original ones, I would say to clean the connections under the bumper. At this time of year if my car has been standing, I can get some random beeping, but assume that is just down to wet/condensation on the connectors as they are a bit exposed to crud off the road and I don't think the tow bar I have help. But cleaning them off regularly does seem to keep the issues to a minimum for me
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
They are definitely factory fit the switch is next to the hazard warning switch and has a symbol similar to a WiFi signal symbol so I presume that's for the reverse sensors.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
The aftermarket stereo was an old JVC which stopped the display on the dash working and stopped the steering wheel control. All these functions are now working but there is still no reverse sensors. Will aftermarket sensors fit into the factory fit holders because I'm thinking for about £20 you can get reverse sensors to fit yourself.
 

·
Registered
Joined
·
687 Posts
The aftermarket stereo was an old JVC which stopped the display on the dash working and stopped the steering wheel control. All these functions are now working but there is still no reverse sensors. Will aftermarket sensors fit into the factory fit holders because I'm thinking for about £20 you can get reverse sensors to fit yourself.
I always thought that was for the factory fitted car alarm. I don't have one on my car and so just have a blanked switch there.
 
1 - 8 of 8 Posts
Top