Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
500 Posts
Discussion Starter #1
When i first got the car (many moons ago) I had the front drop links replaced.
I am now getting a similar knocking noise from the suspension. I have had the front of the car of the ground and i can confirm there is a small amount of play in just one drop arm.
This time the noise seems to come from the rear.
The car recently passed the Spanish road worthiness test, with the clonk . I did not have any failure or advisories.
When I looked at the rear there is nothing I could see that resemble the front drop arms.
The drivability is not affected. The suspension passes the bounce on each corner test too. Thus ruling out shock absorbers.
Question I have what could be making this clonking noise?
 

·
Moderator
Joined
·
5,978 Posts
There are bushes in the rear axle that can wear and also the top hat on rear shocks or the shocks themselves can develop a knock
 

·
Registered
Joined
·
500 Posts
Discussion Starter #3
Thanks for the reply. I will look at the top of the shocks first. I am perplexed as to why this passed the annual test if the any bushes have warn.
I will report back.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #4
Just had the car up on the ramps.
It does seem that the bottom end of the drop links are moving around. We could not find anything wrong with the rear end. Not even the exhaust or spar wheel move. Which is something that crossed my mind.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #6
The front drop links are about to be changed. Then I am off to get my hearing sorted. I could have sworn the cluck came from the rear. 😟
 

·
Registered
Joined
·
8 Posts
Just had the car up on the ramps.
It does seem that the bottom end of the drop links are moving around. We could not find anything wrong with the rear end. Not even the exhaust or spar wheel move. Which is something that crossed my mind.
Hi I had a knocking sound from the rear of my 2007 307 1.6 hdi 110hp, sounded like it was the exhaust touching something. Turns out it was the heat shield above the exhaust was loose, so removed it and bingo...noise was gone.
 
1 - 9 of 9 Posts
Top