Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter #1
Hi guys. I was wondering if anyone knows where I can get a wiring diagram for my car so I can check it all out and work out where a couple of unplugged sensors go.
 

·
Registered
Joined
·
1,133 Posts
Either buy yourself a copy of SEDRE on ebay or register with Peugeot as an independent repairer and pay to get access to the technical data available.
 

·
Registered
Joined
·
350 Posts
Discussion Starter #5
For free? And I only really want it to find out where my pre cat egt sensor goes. I read it effects boost and regen process. Also noticed my cooling fan doesn't work.
 

·
Registered
Joined
·
350 Posts
Discussion Starter #7
I don't think I'll find the connector without it. Hopefully the download has everything. Not getting any fault codes now which isn't helpful at all lol.

What should I compare to find the boost problem? Electrovalve percentage? Pointless checking actual boost to reference as I know it's way off but for some reason the car doesn't
 

·
Registered
Joined
·
15,377 Posts
In all honesty im not sure i have never needed to pay for any extra access i just use it for prices mainly but the 7 euros gives you 1 hour for everything i believe so just be quick and get as much as you can :)
 

·
Registered
Joined
·
350 Posts
Discussion Starter #10
Think I've got to the bottom of it.

The cold start
Hesitation
Bad fuel economy and no black smoke ever. Which always confused me.

Pulled up at college today and sat at idle for 15 minutes. Got out and there's a pool of diesel. It's definitely coming from the pump. It looks like it's coming out of the union from the pump that goes to the common rail. The pump has been changed a couple times so I'm thinking a new pipe is required.

Thanks for all the help over the last year. You were absolutely right about having more than one problem. Although I never thought I'd break this vicious cycle. Thanks for telling me to be methodical and keep at it. It's a small job so it might be a trip to europart and an update later today :)
 

·
Registered
Joined
·
350 Posts
Discussion Starter #11
Found the leak. It's coming out of the back of the pump. There are 2 little sump pan things on it that hold in with small star bolts like mini subframe ones. It's leaking out of the back one. Can I tighten this up or fit a gasket? I snapped one of the bolts that holds the pump to the block and it's a new pump off a private sale so don't really want to take it off. It's in there tight even without the head from one of the bolts.
 
1 - 11 of 11 Posts
Top