Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I don't mind if i can't get the HUD working but just to get the new stereo to work would be great.

I have tried 2x harness adapters and it still won't power up.
i thought it was the stereo i bought but they sent another; which behaves the same way.

I've added some photos but can't add them to this post.
i notice there are around 5 cables in one white block that are excluded from the harness.


There is power reaching the stereo as a blue led inside it turns on.
just can't get either of the new units to actually turn on.
 

Attachments

·
Moderator
Joined
·
5,633 Posts
You have a RT3 head unit it connects to the multi function display via fibre optic link (orange cables in block) it also controls the reversing sensor data via CAN/VAN network the data which is not supported by your head unit or if it is it need the smaller display not the RT3 optical navigation screen

Sent from my SM-T830 using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
You have a RT3 head unit it connects to the multi function display via fibre optic link (orange cables in block) it also controls the reversing sensor data via CAN/VAN network the data which is not supported by your head unit or if it is it need the smaller display not the RT3 optical navigation screen

Sent from my SM-T830 using Tapatalk
Thanks, though shouldn't the new stereo work without these being connected?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
ahhhh just thought.
I have steering wheel controls including cruise control.
I see there are kits that support this too. perhaps I should go to a professional?
just the cost though.
 

·
Moderator
Joined
·
5,633 Posts
The wiring for the RT3 is slightly different to the normal head unit. Google RT3 retrofit and there is a guide to fitting one which shows the wiring which you can use to identify which wires to swap around to power the unit.

Sent from my SM-G965F using Tapatalk
 
1 - 6 of 6 Posts
Top