Peugeot Forums banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi there from sunny Cyprus.
First off thanks the a great forum with lots of useful info.
I have read a few threads on my issue but wanted to see if there was some up to date info around.
I have a 1600 high spec 2002 307. Low miles and everything worked okay until I let the battery discharge over a prolonged return to the Uk.
Then started having issues with the central display on and off.
Just returned from a 2 month visit to UK where I disconnected the battery. Unfortunately the BIS soft stop and restart info was not known to me till now so the battery has been off and on a few times with no regards to letting it sleep and wake up slowly.
So.
No radio and no display bar a faint collection of light to the far right of the screen after driving for 5 minutes.
Everything else works fine and the single cd ejects and lads as per the other threads.
Have I corrupted the bus bar type setup?
Can I reset the system at all?
Tried putting it to sleep and waking it up properly a couple of times as per the correct info to no avail.

Hopefully you can help me.
Cheers for now.:thumb:
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
BSI reset performed.

Tried the BSI reset procedure with the press of the lock for 10 secs. Faint appearance of the central screen now showing flashing figures as per after a power disconnect.
Fuse 11 okay and radio cd worked on a journey yesterday in any case. Stopped working on return journey though!
I am hoping it will sort itself out but not entirely full of confidence.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Hi there took the car to a local auto electrician and they suggest it's the mutifunction display that has s faulty. They are looking to source a used one. Is it likely to be the central display unit? Or is this a passive device controlled by the B S I?
Would a faulty MFD stop the radio from working?
 

·
Registered
Joined
·
15,377 Posts
Display wont stop radio working i use a 206 BSI for coding radios and it has no display plugged in radio still works some radios have a fuse in the rear some dont check that but there is a fuse in the BSI too that covers the radio and display you have a comon fault with both.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Thanks for the replies. The radio cd still has power as the cd ejects and loads still. Could it still be the fuse within the BSI?
Don't have a voltmeter with me over here so unable to check the battery bolts at present.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Swapped out the fuse 11 which is listed as common to both radio and MFD. no change although on close examination with full sunlight shining on the display I can see the correct info for start up. Flashing language choice and temp in bottom right corner even able to select English and then mph and 24 hr clock. So thinking to maybe the3 bulbs that are blown. However that doesn't explain why the radio doesn't work but has power to it.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Replaced the 3 bulbs at the back of he MFD and no change. So the info is on the LCD but not being illuminated and the cd load and unload has power but no other audio functionality available.

I guess I could fit an aftermarket stereo and bypass the MFD completely. Might even be able to get a switched 12 volts to the bulb cct and isolate that from the computer control in place at the moment. Don't want to mess up the essential operating systems though.
 

·
Registered
Joined
·
15,377 Posts
You are missing a power feed after ignition assuming the bulbs are indeed good as the radio needs this and so does the backlighting of the display probably either a broken wire or a bad earth somewhere bad earths can cause strange behaviour.

Again i will say the display wont stop the radio working so its something common to both.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Thank for the clarity reliable406. I will take the radio out next and see what power feeds are present and also check for an internal fuse.:thumb:
 

·
Registered
Joined
·
9 Posts
Hello, did you manage to solve this? The buttons on my peugeot 307 (2006) do not work despite turning on, off and increasing the volume normally, I cannot access the menu and options of the on-board computer.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top