Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi guys

I am wondering if you can help. Quite a long story so bear with me

I have recently got my old 307 through an MOT, it cost me about £300 on bits but I was as I was giving it to my mother in law to use as a favour., because she does not currently have a car. However after a couple of weeks it developed a battery charging fault. I brought a brand new battery but the fault still persisted, so I fitted a different alternator from the scrapyard. This still did not fix the fault and someone said it was because the alternator number was slightly different something like CL8 Compared to CL7 I think.

Even After I had swapped the alternator and battery the car still started and drove fine even though the fault remained.

well my brother in law said he would fit the 'proper' alternator to fix the problem. He has done this and now the car does not start at all.

They have now towed the car back to me and its sat on my drive now and
It is stuck in economy mode and does not start, it turns over fine however it's like it's not sparking . Also most of the electrics seem not to be working like the windows, indicators wipers all I can see is economy mode a a time on the dash. The key button on the dash is flashing quickly so I was thinking it was the immobiliser.?

I have tried everything I can think of, put a new battery in the key and tried the BSI reset procedure but it still not worked, I have event tried putting in petrol, oil and water because I saw it fixed someone else's on another thread. Before it came back from my mother in laws she sent it to A local garage for assesmnt , they said they did not know what was wrong with it but they had tested the immobiliser, battery, alternator, starer motor and coil packs which were fine, they even said they had managed to get it started but I don't see how. they suggested an electrical fault but said they didn't do electrics but I think they just did not want to know as I think it was a favor for my mother in law

I do not have Peugeot plant so cannot even test it and my hand helt fault code reader unsurprisingly shows no faults

Any help or suggestions are greatly appeciated, I just want to get it going now so I can at least try to get my money back
 

·
Registered
Joined
·
4,778 Posts
Hi guys

I am wondering if you can help. Quite a long story so bear with me

I have recently got my old 307 through an MOT, it cost me about £300 on bits but I was as I was giving it to my mother in law to use as a favour., because she does not currently have a car. However after a couple of weeks it developed a battery charging fault. I brought a brand new battery but the fault still persisted, so I fitted a different alternator from the scrapyard. This still did not fix the fault and someone said it was because the alternator number was slightly different something like CL8 Compared to CL7 I think.

Even After I had swapped the alternator and battery the car still started and drove fine even though the fault remained.

well my brother in law said he would fit the 'proper' alternator to fix the problem. He has done this and now the car does not start at all.

They have now towed the car back to me and its sat on my drive now and
It is stuck in economy mode and does not start, it turns over fine however it's like it's not sparking . Also most of the electrics seem not to be working like the windows, indicators wipers all I can see is economy mode a a time on the dash. The key button on the dash is flashing quickly so I was thinking it was the immobiliser.?

I have tried everything I can think of, put a new battery in the key and tried the BSI reset procedure but it still not worked, I have event tried putting in petrol, oil and water because I saw it fixed someone else's on another thread. Before it came back from my mother in laws she sent it to A local garage for assesmnt , they said they did not know what was wrong with it but they had tested the immobiliser, battery, alternator, starer motor and coil packs which were fine, they even said they had managed to get it started but I don't see how. they suggested an electrical fault but said they didn't do electrics but I think they just did not want to know as I think it was a favor for my mother in law

I do not have Peugeot plant so cannot even test it and my hand helt fault code reader unsurprisingly shows no faults

Any help or suggestions are greatly appeciated, I just want to get it going now so I can at least try to get my money back
if you try start then turn ignition off leaving the key in the ignition and open the driver door does it beep to say the key is in, if not then sounds like the bsi has been killed ie its been spiked or has water on it,

i would recommend contacting someone with planet to see if they will drive out to read the codes and look at live data
 

·
Registered
Joined
·
5,904 Posts
Also, eco mode disables all non essential electrical circuits like the radio, electric windows etc to preserve the battery. ECO mode is not a fault, it is a battery saving state and will dissappear as soon as you manage to get the engine running.
 

·
Registered
Joined
·
85 Posts
Put multimeter across the battery on DC volts and start the car and the read out should be around 14v started if its not giving out 14 volts there's something not right with the alternator if its not 14v its not charging the battery.

Heres a wiring diagram for the starting and charging system in case this helps you
 

Attachments

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Thanks for all your replys guys

I think your right . From what I've read I think the BSI has been wiped and needs to be recoded. Unfortunately I cannot get the car to a garage and do not know anyone with Peugeot planet . Is there anyway I can bypass and fix it without planet?

I can't afford to spend much more on it. its only a 51 plate and can't really be worth much more that e 300 I've already spent on it to pass the MOT for my mother in law.

Anyone know if coding the Bsi is a serious problem and how much it cost to fix?
As if it is I'll probably have to scrap it instead, which is a pity really after all my hard work especially as I recently did the head gasket.

Many thanks
 

·
Registered
Joined
·
4,778 Posts
Thanks for all your replys guys

I think your right . From what I've read I think the BSI has been wiped and needs to be recoded. Unfortunately I cannot get the car to a garage and do not know anyone with Peugeot planet . Is there anyway I can bypass and fix it without planet?

I can't afford to spend much more on it. its only a 51 plate and can't really be worth much more that e 300 I've already spent on it to pass the MOT for my mother in law.

Anyone know if coding the Bsi is a serious problem and how much it cost to fix?
As if it is I'll probably have to scrap it instead, which is a pity really after all my hard work especially as I recently did the head gasket.

Many thanks
2 ways are get i on planet or replace bsi ecu and key set
 
1 - 7 of 7 Posts
Top