Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
Hey Guys, i'm after a bit of advice on my old 307 SW 2.0 HDi 110 02 Plate.

It's been having problems starting, which we initially got around by jump starting the car. So i bought a brand new top of the range Bosch Battery (just fits in the engine bay) which had more power and CCA then the battery it replaced. This "kinda" cured the problem, where the car would turn over for a good 10 seconds then fire.

Today however it wont start (yes its cold -4), i've plugged in PP2000 and the coolant temp is reading -4, fuel temp is -3 and air temp 3.

On the Principle parameters page 1 the fuel pressure during turnover starts at Zero and builds up to 300 to 400 and then drops back down to 0. the parameter underneath pressure difference i think then reads about 218 bar...

Normally when the car does start its fine. Bit lumpy for 2-5 seconds and then there are no issues at all. Go for a drive, come back, get in and starts almost first turn of the key.

The problem only manifests itself after a long period of time and is made even worse by cold temps.

Things on my list are started motor and HP Pump, both expensive....

BTW Glowplugs have all been changed and no error codes given....
 

·
Registered
Joined
·
61 Posts
Discussion Starter #2
all of the above happened this morning and at lunch time, come 5 o'clock the wife goes and tries the car again, starts after a few turnovers...... :confused: :eek: temp has really risen at all during the day - at lunch it was showing -3 in the car display, this evening still the same.... why are cars so confusing???
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
More info

So the wife has been out and come back, so thought i'd hook PP up and take a look. Here's what I got:

Engine Speed: 803
Camshaft Sync: Yes
Fuel Pressure: 298 Bar
Difference: 2 Bar
Diesel Pressure Regulator OCR: 17%
Injector Flow Setpoint: 11mm3/stroke
Flow Correction 1: 0.2mm3
Flow Correction 2: 0.04mm3
Flow Correction 3: 0.35mm3
Flow Correction 4: -0.59mm3
Injection Voltage: 80V
Air Flow: 518mg
EGR Valve: 99%
EGR Throttle: 95%
Diesel Pressure Regulator: 658mA
Pre Injection Advance: 11 Degrees
Main Injection Advance: 1 Degrees
3rd Piston Deactivated: No
Turbo Pressure: 1012mbars
Turbo Reference Pressure: 1153mbars
Turbo Pressure OCR: 88%
Atmospheric Pressure: 1012mbars
Coolant Temp: 57 Degrees
Air Temp: 37 Degrees
Fuel Temp: 19 Degrees

Anything look out of place? MFD was showing -2 Degrees.
 

·
Registered
Joined
·
80 Posts
hi

hi there i see you said the glow plugs were changed but when i had mine done they all were not getting power due to connectors were not cleaned before fitted so not making a complete curcuit and dont think the glow plugs work on these until below a certain temp on the other hand you might have a air leak on the fuel lines
 

·
Registered
Joined
·
14,253 Posts
Its not glow plugs

You say fuel pressure rises then drops again this is not correct whatever is causing this is your likely problem but then you might just mean it drops when you stop cranking if so then its fine unless it drops realy quick

If your car is bosch injection i would look at the tank pump as sounds like the fuel is not filling the filter quick enough for initial start

That is assuming your fuel filter is ok and the case is not leaking

After that your onto leak of tests on injectors
 
1 - 5 of 5 Posts
Top