Peugeot Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My uncles got a 2l 307 xsi hdi and it has trouble starting from cold, he's either checked or changed the following and had them tested, all working.
injectors
starter motor
battery
glow plugs
fuel pump
It's only done 68k and can't figure out what else it could be, any one got any ideas he could try? Spent alot on parts already to try and get it working.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
It turned over for 10 seconds without starting first time, tried it another 4 times turning it over for 3 seconds each time and eventually it started, it's about 2 degrees but my uncle said it's been doing it for a while now.
 

·
Registered
Joined
·
399 Posts
Think it would be best to plug it in to a diagnostic kit.
Some one might have a peugeot planet near you there's a list of people on the main forum page.
You could try changing the fuel filter! Might help..
 

·
Registered
Joined
·
3,426 Posts
mine starts instantly no matter what the weather. might be worth a trip to a garage where they can test the battery

how long does the glow plug light stay on?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Battery has been changed and the glow plug light stays on for a few seconds, apparently he's been told the glow plugs only turn on when the temp is below -1-3ish, but i've got a tdi ibiza and i'm sure they come on everytime you put the ignition on?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
When you turn the key in my ibiza you can hear the fuel priming, when you do it on the 307 nothing happens, does it prime on yours? My uncle thinks it could be losing pressure in the fuel lines after the pump, it starts fine once it's been running.
 

·
Registered
Joined
·
14,535 Posts
If your uncles 307 has siemens injection it wont have a tank pump

Glow plugs are not worth worrying about they start even with all of them broken :)

fuel leakback is a possibility tell him to prime the primer under the bonnet before trying to start see if it improves
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
Tried that, squeezed it a few times tried starting and the tried squeezing it whilst he was turning it over and still nothing
 

·
Registered
Joined
·
14,535 Posts
You need to plug it into planet get a bit of info on whats going on NOT read codes actual parameter readings
Crank sensor signal might be poor sometimes they get covered in filings and confuses them pull it out for a look its in the top of the bellhousing
 

·
Registered
Joined
·
593 Posts
my 307 is same. i have to put footdown to start. its then jumpy in revs until bout 3k then i release and hell loads of blue smoke comes past the windows. after that away she goes. ive got planet and noting shows up.
 
1 - 13 of 13 Posts
Top