Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi all, Im new to the forums. This is my first post. Recently purchased an '02 307HDi (90). have noticed over the last couple of days that there is a smell of exhaust coming into the cabin on startup and for the first minute or so (I have to open a window to clear it). I was wondering if anybody knows what the problem could be and how to sort it. It has done 94k miles. Just had the cambelt changed.

It also seems underpowerd compared to my Focus Tddi (90). With that car you can hear, and certainly feel, when the turbo comes in, it just seems that the 307 is lacking in power and you really have to drive it harder to get anywhere reasonably quickly.

Thanks in advance for any help. Nige.
 

·
Registered
Joined
·
176 Posts
I had a similar problem....

I'm assuming that the layout of the 307 (90) version (1.4HDI) is almost the same as the (110) version (1.6HDI)

There is a clamp on the 110 that locks the turbo onto the particle filter (a C-Clamp). If the clamp is out of place, loose or otherwise damaged then the exhaust gasses leak under the bonnet of the car and end up being circulated into the cabin.

The same happens if the turbo isn't perfectly mated into the exhaust system.

Easiest way to check is on a cold day. Open the bonnet and then start the engine; you should see any obvious smoke.

If the problem is by the turbo and some nutter in a garage says "Replace the Turbo" try the following first.

Remove the clamp where the smoke is coming from and use a sealant paste, then replace the c-clamp (make sure the engine is cold when doing this (bellow 60 degrees cent) after that check that the clamp is covering each side of the connection equally before tightening.

If your particulate filter is under your car (110 is front mounted vertically) then you might have to put it up on a lift to see exactly what's going on.

I hope this helps if it turns out to be a similar problem.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Many thanks for the replies. Forgot to mention that its a 1997cc hdi (90). Im not sure how similar it is to the layout of the 1.4 or the 1.6 but will have a look for any leaks the next time i start it up. Many thanks.
 

·
Registered
Joined
·
176 Posts
In a few years I'll replace the engine in my car with a 3 phase squirlcage motor (20 to 25kw) or a brushless DC motor. I'll get a few people I know to help and install an ACH550-01-114A-2+B055 that can run on DC input (for an AC motor).

Reconditioning this unit is not extremely hard for me and since I work in heavy industry these are always being replaced so with any luck I'll pick up one cheaply.
They are about 75 cm long by 35 cm wide (bye bye to the boot/rear of the car)
http://www.sentridge.com/acatalog/info_ACH550_01_059A4B055.html

0 to 60mph time would be about 8 seconds from that size of electric motor relative to weight

Keeping the clutch system will be a challenge and tying to find someone to reprogram the CPU of the car will be a nightmare.

Battery packs I can get from car breakers (Honda hybrids units)
 
1 - 10 of 10 Posts
Top