Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So...i'v just bought a 2007 307 SW 1.6Hdi. It has some annoying niggles which I would like to get sorted...I believe trustme is the man with all the knowledge.

So...Remote central locking. I have one key only so need to get another key coded (I have the key security credit card thingy) my main problem is having managed to program the key fob to unlock the doors with the buttons....it only works within about 6 inches of the ignition switch. Is this a key fob fault or a car/BSI fault? (Already done a BSI reboot)

Cruise control works intermittently...have replaced the reverse light switch as I was getting a random indication whilst driving along that the reverse sensors had kicked in...again...is this a BSI fault or should I be looking at switches on the brake pedal?

Auto on rear windscreen wiper...started randomly washing and wiping my rear window whilst driving along the motorway yesterday....BSI?

Annoying little niggles that hopefully I can get solved reasonably easily.

Thanks in advance for your help guys
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks gibbo, that was gonna be one of the first things I was gonna try...also the switch that's in the image...no idea what it is and where it's located...but figured do the cheap and easy things first....think I need to invest in a Haynes manual too :(
 

Attachments

·
Registered
Joined
·
548 Posts
....it only works within about 6 inches of the ignition switch. Is this a key fob fault or a car/BSI fault?
Quite possibly low key fob battery.

Cruise control works intermittently...have replaced the reverse light switch
As said this could easily be the brake switch

Auto on rear windscreen wiper...started randomly washing and wiping my rear window whilst driving along the motorway yesterday...
If anything like mine this sounds like a coms unit fault. Mine did this randomly when I bought it 4yrs ago. Eventually towards the end of last year it also developed a random headlight flash so I replaced the whole unit with a brand new one.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Hi Ash, tried new batteries...no difference unfortunately.!

Do you reckon this could all be a Com 2000 fault....every symptom? :confused:
 
1 - 5 of 5 Posts
Top