Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi guys just purchased a 307 cc 05 plate, i feel the car runs a bit sluggish especially when cold even after a 30min drive it still feels sluggish, you can feel it holding back, however if you rev the engine in neutral it seems to rev ok, i have had it into peugoet twice and they have put it on diagnostics updated the software for the ecu but cant find anything wrong although they did not road test it, i have arranged to go out with a technician in a couple of days so hope a problem is diagnosed, only had the car three weeks but am already feeling let down. anyone with any ideas ?

thanks, jim
 

·
Registered
Joined
·
862 Posts
james mcpherson said:
hi guys just purchased a 307 cc 05 plate, i feel the car runs a bit sluggish especially when cold even after a 30min drive it still feels sluggish, you can feel it holding back, however if you rev the engine in neutral it seems to rev ok, i have had it into peugoet twice and they have put it on diagnostics updated the software for the ecu but cant find anything wrong although they did not road test it, i have arranged to go out with a technician in a couple of days so hope a problem is diagnosed, only had the car three weeks but am already feeling let down. anyone with any ideas ?

thanks, jim

Hi and welcome to the forum :thumb:

Is your car petrol or diesel?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
hi its petrol 1.6, just had the technician take the car out today he still says there is nothing wrong, he said maybe im not used to the drive by wire but i still think there is something wrong, i think ill try a different peugoet dealer for a second opinion.

also when i start the engine sometimes i get two beeps, no warning lights or anything on any advice.

thanks, jim
 

·
Registered
Joined
·
256 Posts
To my knowledge drive by wire systems are not available, electric assisted steering is, but wire drive steering is only available on the upper spec bmw's and merc's, So what is your dealer telling you, check the fuel systems for contamination, also the two beeps on start could possbly be a fault immobiliser which is sending incorrect codes to the engine management system.
 
1 - 5 of 5 Posts
Top