Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hey lads and ladies .
Sorry I bet both have been over done but I'm trying to browse on a phone so hard to search .
If so maby link the threads for me :)

My 2002 1.4 hdi 307 has braking fault , abs fault , handbrake light and stop on the dash and Speedo stops after 25-30mph.
Both rear speed sensors are my faults logged .
Before replacing I wanted to check here if this would be a genuine fault or could be something else .
( I've noticed handbrake has play lately)
Maby not related .

Also intermittent it feels as if it's been switched off . Zero power then returns fine again. No engine codes logged .

Please help before I go buy bits

Thanks in advance :-D
 

·
Registered
Joined
·
2,177 Posts
Braking fault is most probably caused by rust under the rear ABS sensors. They need removing, carefully, and all the rust cleaned from under them until solid metal once again reins! A touch of de-rust and a spray of grey primer and refit and take for drive as the system needs to see a speed signal from all 4 wheels to rest.
This intermittent fault might be limp mode. At rest out of gear does the engine speed rev to over 3000 rpm or better still floor the throttle and see what it registers and report back.
 

·
Moderator
Joined
·
2,979 Posts
Yep had the above problem on my 307...removed the abs sensors and using a centre punch de-scaled the mounting holes ,refitted sensors and all was well....
 
1 - 3 of 3 Posts
Top