Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi guys,

I am based in Kent (coast) and have a 307 1.4 hdi and a 307 1.4 petrol (Plus a few others.

My HDI is my daily and has been faultless for the last 4 years. This year it has decided it wants some money spending on it :)

The problem I have is the engine cooling fan. Basically it doesn't work with AC on or when warm.

I have gone in with my Omitec diagnostics and can get both slow and fast fans to run via that, If I disconnect the temp sender (new) the high speed fan runs.

But driving along with AC on the fan is not running on slow and when temp increases slow and high do not run.

I have replaced the sensor in the rad but mine looked on. I have ordered a new temp sensor (green) but the one in the car is only a couple of months old as I replaced the thermostat)

I have checked fuses in engine bay (top ones) and all are good. aircon is gassed and compressor clicks in and out but no fan activation so no cold air.

Is there anything else to look for? I am assuming relays in rad are good as I can activate the fan via diagnostic, also assuming fuses good,

Obviously as weather is so hot I have parked the car until I can sort the issue.

The other 307 I bought with drivers door dropped and catching striker plate. Am I correct in assuming the wing needs to be removed in order to adjust the hinge bolts? Is this a nasty job? :)

Thank you for reading. Look forward to hearing peoples thoughts.
 

·
Registered
Joined
·
1,109 Posts
When I replaced the doors on my wife's 307 just removed the hinge pins and swapped in the new door. I can't remember exactly what was involved, but it was quick and easy. Certainly I didn't need to touch the wing, :):thumb:

Roger.
 

·
Moderator
Joined
·
6,000 Posts
Not sure if the hinges are bolted or welded to the A-pillar. If they are bolted then the bolts are accessible for the inside of the car if you remove the side trims from the footwells.

However as above hinge pin wear is the more likely issue that dropped hinges
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Hi

Thanks for the replies.

It is definitely the hinges (maybe door was changed) that need adjusting.
It looks to be bolts into captive nuts but I will check further.

I cannot get a spanner into the A pillar hence my question regarding the wing.

Back out to the car it is then :)
 

·
Moderator
Joined
·
6,000 Posts
Double checked on service box and yes you are right bolts from outside into captive nuts in A-Pillar. I would think a good wobbly socket would get in there without removing the wing
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Double checked on service box and yes you are right bolts from outside into captive nuts in A-Pillar. I would think a good wobbly socket would get in there without removing the wing
Thank you. Will try that but not sure it will work :)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
On another note ref aircon and cooling fans.

I have regassed the aircon but fan not cutting in on low speed. Now has new sender and dual fasn speed sensor.

Fans work fine when prompted through omitec

So that tells me fuses and relays must be good.

Any other idea's where to look?

I could change the relays but cant see the point if the fans work?

Am I missing another relay anywhere?

Thank you kindly :confused::lol:
 
1 - 8 of 8 Posts
Top