Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
307...51 plate..2.0 xsi

I have not got a clue where to start..cant get it off ECO mode .it has come off eco mode recently for about 10mins and the electrics were all back to radio has loud beep ..but still could not get to start.. Now back in eco mode..the only beep i get is passenger side door opened while putting the sidelight on.it turns no probs but just not firing also cant lock doors with key fob apart from drivers door lock etc. etc. and red flash rapidly on centre lock button..it feels as though the immobilizer is active and will not switch off.any checks that i should do first?

It looks like the imobilizer is stopping everything from working..but prob wrong as I am new to this..

any help would be grateful..
 

·
Registered
Joined
·
5,906 Posts
It sounds like the BSI has lost some of it's programming. Radio usually beeps because it hasn't been programmed withe the cars VIN. Eco mode is not a fault. It is the computer turning off all non essential electrics to conserve battery power for the next start and will go away once the engine is running. If the BSI has lost some of it's programming then it may need the keys reprogramming through Peugeot Planet 2000 or Diagbox diagnostics. You will need the code from the security card to reprogram the keys. If this is the case then the immobiliser will not unlock the ECU and allow the engine to start.

It's possible that you have a battery problem or one or more earth leads are loose or corroded so not making a good connection. Check the earths and ensure the battery is fully charged. If it still doesn't start then you would probably need to get it hooked up to planet.

You can check the planet map to find someone close to you who is willing to come and run a check on the car. This will show if the ECU is unlocked and if it isn't could program the keys if you have the code. Hopefully the BSI isn't toast.

https://www.google.com/maps/d/viewer?ll=54.265224,-3.383789&msa=0&spn=10.238651,28.54248&mid=zWo6S8V8_aAo.kmA902W5aW7Y

To get your post count up to PM a member you can post to your hearts content in this thread.... http://www.peugeotforums.com/forums/general-discussion-2/need-20-posts-before-pm-13646/
 

·
Registered
Joined
·
14,268 Posts
eco mode is NOT a problem merely a symptom ignore it once car starts it will be gone

The key needs to be read by the BSI to unlock the immobiliser so it sounds like its a BSI issue in some way the beeping radio means the radio and bsi do not match again could be a BSI issue has the ecu set been changed or ANYTHING been changed prior to this issue
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks. .
As far as I know..When it first went into economic mode .I had taken the battery out and not the correct way thinking it was flat. .
It has come out of economic mode once but did not start and the electrics were all back to front. .I changed the battery in the key fob but still no avail..The only thing I have been doing is charging the battery overnight a few times to see if will work. I really don't know much about cars as this is my first as was working perfectly before this started about it months ago and hasn't moved. .just have the planet and diagbox software but I think I need the proper cables. .I will keep trying and hopefully get it sorted. .
.
Thanks for your help members
 

·
Registered
Joined
·
168 Posts
yes planet is your best option on this by the sound off things, if you have one - have you tried the other key!!
 

·
Registered
Joined
·
14,268 Posts
Sounds like you have lost the key codes but the beeping radio says to me your BSI is blank it can all be fixed with planet and some help from here you need a 4 digit access code to recode your keys then the BSI will need reconfigured possibly

You may be lucky and only keys and radio needs sorted.
 

·
Registered
Joined
·
168 Posts
When mine went in to eco mode,I did not have the beeping radio but I did have the flashing red and Amber on the centre of the dash,if you click on gibbos link or just post your area ,you will get PP2000 diagnostics help ,it will save you banging your head on brick wall for weeks,I should have contacted the guys on here alot sooner.
As reliable mentioned you need a four digit code.
Three options

1 you got it with the car on a card when you bought it
2 contact some one on here,possibly bettyswallocks but not sure
3 take your car docs and I'd down to your local pegeout dealer,as you own the car they may not charge,
When I called pegeout they didn't mention a charge but I didn't eventually need the code so I may be wrong.

Hope you get it sorted as I know how frustrating it is,,

Ed
 

·
Registered
Joined
·
168 Posts
Just to add to storemans post also ,get the diagnostics done first as your key may still be registered to the ecu like mine was,
 
1 - 10 of 10 Posts
Top