Peugeot Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

This is my first post and I am hoping that somebody can help me out.

I own a 2007 307. I wanted to change the stereo in it for a more flexible option (mp3 player etc).

I have taken the stereo out and noted that it requires a mulitplex wiring adapter, to convert to ISO which I purchased.

I fitted this correctly and the new stereo.

When trying out the new system I expected that the steering wheel controls for the stereo would not work, however...

My 307 has a speed limit and cruise control stork. The limiter works fine but the cruise control does not.

I switched stereos and it all worked fine. Is there any way that I can get the cruise control to work or is it never going to work with this style of peugeot wiring?

Thanks.
 
G

·
Hi and welcome!

I dont have first hand experience, but have read that what you are experiencing is sadly what happens.

The earlier 307s had a traditional ISO plus bus, and were easier to change. You still loose trip computer, time setting etc though, even with them.

The steering wheel controls will be down to your bus adapter. I would expect it to work, so probably best speaking to the place that sold you it, or probably beeter, track down the manufacturers website and see what it says.

David
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for your reply...

GREAT NEWS!!!

I have replaced the stereo yet again with an older (3 year) JVC model and everything works (except steering wheel audio controls).

The trip computer, speed limiter, cruise control, lights, central locking the list goes on. All except the time readout.

I think, and this is my opinioin the Ripspeed unit is not compatible with any new peugeot having spoken to a couple of people.

sps
 
G

·
Another thing worth noting is that after fitting a stereo its worth doing a bsi reset

I was getting allsorts of mad stuff going on after i connected my stereo to my volume control stalk, only a bsi reset solved it for good (mainly windows and doorlock problems, might not even be related to the wiring i was doing, but it happened straight after i'd added the adapter!)

I assume its like a PC in the sense that adding extra hardware while its switched on isnt a good idea :D
 
1 - 4 of 4 Posts
Top