Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
hi guys back again , car went good for 2 days now the turbo will boost somwetimes then next gear the car will not rev about 2000 rpm
then on idle it wont rev out any ideas what i should check next
the car got a new turbo solenoid , n wires reconnected
the car is bringing no faults up on peugeot planet
 

·
Registered
Joined
·
1,045 Posts
check your EGR is not stuck open unplug the blue plug on the solenoid thats works your EGR.

then if its the same unplug the MAF sensor to see if you have full power back if no good then last thing to do its your MAP sensor the the intercooler is deal (rare that these fail)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
307

Thanks again mate I will try in morning if I disconnect the egr solenoid will that make It run better , also map sensor is the one on top of the Inter cooler ? Hopefully get to the bottom of this it's gettin annoying lol I just find it strange that there no fault on peugeot planet . Thanks again for ur help
 

·
Registered
Joined
·
1,045 Posts
the MAF should give you a code as well as the one on top of the intercooler so am guessing EGR valve as this should give a code but not always,
also check your clamps on the turbo hoses, get someone to rev the car hard to 3k while you hold the top boost hose and see how hard it gets if
its weak then i would check your hoses, but uplug the EGR first and road test she if the power is back and if it is then you can just leave it unpluged
but i would just block the EGR :p
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
307

I disconnected the egr car still won't rev out the top boost pipe Is full off pressure when rev the car ,
Basically what is happening now is at idle u could rev it to red on limiter the. Let the throttle off back until idle then it won't rev past 2000 loafs soon white smoke n misfire
I'm starting to panic here lol any ideas now ?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
307

Quick update guys
I disconnected the airflow meter
Turbo every gear n running ok
It's was only a new genuine peugeot airflow last week
Could it b bad already or is it bad wiring to the airflow ?
 

·
Moderator
Joined
·
11,711 Posts
Could be bad wiring but I'd get a diagnostic to see what fault code is coming up.

If the MAF is faulty or mis-reading it will being up a code.

Try giving the electrical plug a really good soaking of electrical contact cleaner.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
307

With it not connected planet is bringing up permanent fault open circuit ,
With it connected it is bringing no faults should I check live data on air intake ,
I have drove to work in it with airflow unplugged driving good ,
Will it do any harm to car ?
 

·
Moderator
Joined
·
11,711 Posts
1. With it not connected planet is bringing up permanent fault open circuit ,
2. With it connected it is bringing no faults should I check live data on air intake ,
3. I have drove to work in it with airflow unplugged driving good, will it do any harm to car ?
1. Yep, that's correct.
2. Yes.
3. Not as far as I'm aware but it will consume more fuel and won't be giving the right intake air temperature readings to the car.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
307

So what value should I b looking for on idle etc ? I can't understand at as it runs perfect with it disconnected. Maybe the airflow meter is not getting the correc power or something
 
1 - 10 of 10 Posts
Top