Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
hello folks new to this site , need some help
basically bought 307 2 months ago has 70k recently got hard to start n run n idle bad so therefore has had lots off money spent to fix problem which mechanic told me it needed
has had 4 recon injectors , recon hp pump , new low pressure pump , cam / crank sensor, geniune airflow meter , new fuel housing and filter, plus more.
the car is no better hard to start in morning sometimes flattens battery
when car does start it runs n misses on idle just doesnt sound like a hdi engine
peugeot planet fault at minute is turbo pressure signal bad earth or open circuit which i will investigate 2moro - antipollution fault on screen.
if anyone can help it would be greatfully appreciated
i have a feeling it something to do with wiring as it looks as if some1 has opened wiring loom many thanks
 

·
Registered
Joined
·
4,777 Posts
hello folks new to this site , need some help
basically bought 307 2 months ago has 70k recently got hard to start n run n idle bad so therefore has had lots off money spent to fix problem which mechanic told me it needed
has had 4 recon injectors , recon hp pump , new low pressure pump , cam / crank sensor, geniune airflow meter , new fuel housing and filter, plus more.
the car is no better hard to start in morning sometimes flattens battery
when car does start it runs n misses on idle just doesnt sound like a hdi engine
peugeot planet fault at minute is turbo pressure signal bad earth or open circuit which i will investigate 2moro - antipollution fault on screen.
if anyone can help it would be greatfully appreciated
i have a feeling it something to do with wiring as it looks as if some1 has opened wiring loom many thanks
check wiring to diesel pressure sensor on the common rail red connector if you follow it from the common rail there will be a yellow connector solder this out and see if it makes a difference also check all the wiring in the harness just under the fuel filter because if diesel has spilt on these over time they corrode
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
307

Thanks for the help I will give it a go in afternoon
Forgot to say peugeot dealer put it down to low pressure pump which I replaced with a brand new 1 . Also all data on planet seems good
300 bar hp, 803 rpm steady on idle
But still sounds terrible as if it off cylinder hunting etc
I will try these wires n report back thanks for ur help
 

·
Registered
Joined
·
548 Posts
Thanks for the help I will give it a go in afternoon
Forgot to say peugeot dealer put it down to low pressure pump which I replaced with a brand new 1 . Also all data on planet seems good
300 bar hp, 803 rpm steady on idle
But still sounds terrible as if it off cylinder hunting etc
I will try these wires n report back thanks for ur help
Get a video/sound recording of it idling, the 8v HDI is not the quietest/smoothest diesel in the world however it shouldn't sound as if its missing. A video may just help other diagnose your problem as its strange planet does not reveal anything.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
307

Hi guys went to car to try this morning before doing anything to it , car not start flatten battery peugeot planet has only low turbo pressure fault

I soldered the the yellow plug out n still no joy
Anything else I should check ?

Thanks guys
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
307

Hi guys got car going took off n cleaned all earth points
Put charger pack n car started n is now running n idle real good , thanks for ur help at min hopefully after if sits for a while it will start first time

Only fault is turbo pressure signal fault open circuit or bad earth any ideas were to start on this one lol ??
 
1 - 8 of 8 Posts
Top