Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter #1
Hi, my girlfriends car seems to be playing up a little bit, sometimes it feels normal with the turbo kicking in other times it feels like there is no turbo really sluggish weird as it's just does it when it feels like it.
Thanks
 

·
Registered
Joined
·
52 Posts
MAF sensor?

Have you removed the MAF sensor and cleaned it?

Use switch cleaner from Maplins. (Own brand or Servisol etc. We radio hams use it to clean circuits.) Spray liberally onto the probe in the sensor, and let it dry naturally. Do not use WD40 or similar products. The sensor is an electronic component and won't take too kindly to it.

Might be that it is dirty.

When was it last serviced with a new air filter/fuel filter?
 

·
Registered
Joined
·
4,778 Posts
No I haven't yet I will try that :). I serviced it about a month ago so that should be all good.
Cheers
it could be maf when its doing it see if it runs better with maf unplugged, could be turbo electro valve try swap it with egr electro valve, it could be egr valve remove vacuum pipe and block the pipe to stop the vacuum leaking
 

·
Moderator
Joined
·
5,891 Posts
Pop the vac hose off the vacuum pump and squirt a bit of oil into the pump reconnect hose and see what happens

I know of a fair few cases where the non return valve in vac pump starts to stick giving these symptoms
 

·
Registered
Joined
·
1,424 Posts
that vacuum pipe appears to go under the Engine .well it did on my car , after someone jacked it up using a block of wood under the engine the pipe got crushed most disconcerting at the time
 
1 - 8 of 8 Posts
Top