Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi guys , been reading the forum for a while now and got some great Info , thanks to all .


I have a 2005 307 1.6HDI (110) that has been complaining about the EGR valve for a few weeks now , I have not got round to fix it but will be doing this week , I have now got another problem and was wondering if its just the EGR valve has died .

the car lacks some power , I can hear the turbo , but the car sounds like there is an air box off .. ( i have had a good look and cant see anthing loose)

when i hit a hill i get the warning (risk of partical filter blocking) then this goes off after a few miles.

any ideas ?


thanks
karl
 

·
Registered
Joined
·
552 Posts
Hi guys , been reading the forum for a while now and got some great Info , thanks to all .


I have a 2005 307 1.6HDI (110) that has been complaining about the EGR valve for a few weeks now , I have not got round to fix it but will be doing this week , I have now got another problem and was wondering if its just the EGR valve has died .

the car lacks some power , I can hear the turbo , but the car sounds like there is an air box off .. ( i have had a good look and cant see anthing loose)

when i hit a hill i get the warning (risk of partical filter blocking) then this goes off after a few miles.

any ideas ?


thanks
karl
Can you elaborate on complaining?

I'm fairly confident that your EGR is probably just full of crap, and thus doesn't operate to full extents, and sticks.

It sounds to me like your having FAP issues, potentially an almost blocked one. For this to be followed up it's probably best you get the codes read, plenty of people on here are willing to offer their services for a significantly reduced fee vs the dealership.

Phil
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
To elaborate more on the complaining , I got the usual "depollution system faulty" with an engine management light , a few weeks ago ( about 7/8 when i think about it :0 ).. so i got a friend to get the computer on it with Pug planet this flagged up the egr valve.


Anyway the car started to sound like an airbox was off a few days ago and a slight loss of power , If i take it on the motorway the car has plenty of pick up in the high rev range just seams a bit sluggish when I hit a hill at low speed.

I will be getting the computer back on it soon , I just thought you guys may have some idea off the top of your heads.


karl
 

·
Registered
Joined
·
44 Posts
If you can get it read as explained above.

As for the DPF (FAP) at risk of blocking I would get the car on the motorway and give it a good blast, doesn't have to be really quick just keep the revs up above 2500rpm for about 30 minutes. This should cause a regen of the system and clear the DPF filter for you.

I had an egr fault showing on one of these and once the dpf was sorted the egr fault just needed clearing and nothing more.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
the car does NOT get much motorway miles , with my job I only travel a few miles to each location around my town , non of which are on the motorway .


What im worried about is the noise that sounds like a pipe is off
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
no the noise is not obvious , only seems to be as you rev the car and seems worse if the need to pull more , say setting off on a hill
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
sorry for the late reply guys, I cleared the error after the EGR valve was reaplced and another ecu scan today throws up these errors.

P1351 preheat realy stuck in open poss
P0420 Exhaust differential pressure sensor signal partical filter overloaded
P0299 turbo pressure electrovalve, turbo to low compared with setting
P2032 Catalitic converter downstream temperature signal short curcuit to earth.
P0100 flow meter signal , airflow not pausable.
P3008 flowmeter, airflow not pausable (max value)
P0483 cooling intergrated into ECU(FRIC), open circuit or temp to high.
P1447 exhaust differential pressure sensor signal partical filter blocked .

the engine management light is NOT lit ?????? but still i have all the errors after the EGR valve was replaced.

karl
 
1 - 9 of 9 Posts
Top