Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi... can anyone help...
I think there is a problem with my rear light cluster... first the reverse light stopped working (tried a new bulb and didnt work) and now the main rear light isnt working... is there a commonality between them that i can check...
Thanks for any help...:thumb:
 

·
Registered
Joined
·
5 Posts
Hi mate, i have a 307 (2002) .You can remove and inspect the whole rear light cluster quite easily if your main light has now stopped working it just probably means the bulb wants replacing. I changed my reversing light and then my indicator bulb stopped working i replaced that and now every thing is ok again.The solder on the ends of the bulbs is a bit crap so if the bulb looks suspect at the solder change it! take no notice of the filament it can look ok but not work .
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
well it may be the bulb for the main light... but just thought it was coincidental that both had went so soon after each other.... and the fact that the reverse light still doesnt work... even with a new bulb.... is there a relay for all the lights ???
 

·
Registered
Joined
·
25 Posts
jeffr said:
Hi... can anyone help...
I think there is a problem with my rear light cluster... first the reverse light stopped working (tried a new bulb and didnt work) and now the main rear light isnt working... is there a commonality between them that i can check...
Thanks for any help...:thumb:
The terminals on the light fitting itself tend to build up with white residue. Clean the terminal and the plug (scrape with a small screwdriver) and see if it helps. Then theck the bolds make sure they have clean contacts.
 
1 - 4 of 4 Posts
Top