Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys, I am new here, but I hope someone can help, I have a 207 and nearly every time I switch off the ignition the lights and front windscreen wipers turn on, draining the battery, I have put a new battery on but still no luck.

Just wondering if anyone has suffered the same problem and know of a solution.

Thanks in advance.
Nick
 

·
Registered
Joined
·
362 Posts
Hello Nick,

It seems like your comm2000 module is failed. This module is located at steering wheel, where lights and wipers control columns are. Use forum search tool as this is a common failure. Usually failed part is repairable as a new one is some expensive. See also A brief FAQ and Guide for New Members, item 13.

Hope it helps, erick
 

·
Registered
Joined
·
1,061 Posts
Is it the sidelights or headlights that come on? Reason for asking this is because the sidelights are fed from the BSI by the gas pedal and headlights and wipers are fed from the engine fusebox. Check the engine fusebox for any sign of water entry.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks erick-r I have read a few blogs and posts that refer to the comm 2000, it may be worth while replacing it, do you know if I can just swap like for like or do they have to be re-calibrated. I dont have have auto lights or wipers.

Thanks again for the fast reply
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thanks wynb, It is the main headlights that are coming on, there is no signs of any water or water damage in the fuse box.

If I replaced the fuse box, could I just swap it without any re-calibration to the ECU.

Thanks again for the quick reply
 

·
Registered
Joined
·
1 Posts
Hi Nick, I'm having same issue with my Peugeot... any updates on yours and what/how it got fixed please.
I'm worried the car electrician will cost me more than the cars worth.... cheers
 
1 - 6 of 6 Posts
Top