Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi, my pug cut out on me the other day after the anti pollution light had gone out. Now u der hard acceleration she jerks for about a second then runs normal. Just had new timing belt clutch and been fully serviced. Can anyone help im in darlington.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #2
Well today she has chugging along under hard acceleration. Ive found air in the fuel system, beld it out but seems to be getting more in but dont know where from. Have just bought a egr block off plate so will fit that tomorrow.will it need a remap?
 

·
Registered
Joined
·
4,784 Posts
Well today she has chugging along under hard acceleration. Ive found air in the fuel system, beld it out but seems to be getting more in but dont know where from. Have just bought a egr block off plate so will fit that tomorrow.will it need a remap?
what engine would be useful info also what you have tried so far and have you had it on diagbox to check for faults or look at live data
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
1.4 hdi 2007. Not had it garage yet. Im pretty mechanically minded having done all the jobs on her myself. Going to put egr blanking plate in today and will put new oil filter on this week. Fuel and oil filters where only changed in march. Timing belt and water pump im march with 73000. And the belt was nearly shagged.
 

·
Registered
Joined
·
173 Posts
On the 1.4 where the airbox sits it rubs the fuel lines quite often causing a small hole that let's air in the system
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Well had her to the garage. No major falut codes and blanked the egr off. Car was running fine again then today she cut out today. She is only doing it when cold. The garage said there was a fault code for the glow plugs which i will get new but i dont think this is the problem. Once warm she runs sweet.any ideas?
 

·
Registered
Joined
·
3 Posts
I seem to have a similar problem mine cut out while driving and displayed anti pollution fault, it turned over a while then started and was fine seemed like an airlock.
I have noticed since I changed the fuel filter a couple of months ago that it had been erratic on idle and engine seemed to cough at low revs but fine when accelerating but as no real way of bleeding the air out of diesel had to just hand primer bulb hope it would self bleed.
Plugged it into computer and it's come up with 3 fault codes

P0001 (fuel volume regulator circuit open)
P1166 also fuel pressure related
P1471 unknown

So still thinking along the lines of possible air in diesel me get have to try another fuel filter as went for the cheaper crosland unit will try the Mann one instead.
Not sure if any of this helps but hope you've managed to solve it.
 

·
Registered
Joined
·
4,784 Posts
Well had her to the garage. No major falut codes and blanked the egr off. Car was running fine again then today she cut out today. She is only doing it when cold. The garage said there was a fault code for the glow plugs which i will get new but i dont think this is the problem. Once warm she runs sweet.any ideas?
if you read the posts someone has suggested to check the fuel lines under the airbox this is a common problem but it looks like you are ignoring them, also was it dealer level diagnostics used if not then i would recommend using dealer level as there might be some codes the reader has missed also you need to have a look at live data

have a read of section 8 and 9 here http://www.peugeotforums.com/forums/introductions-28/brief-faq-guide-new-members-83170/
 

·
Registered
Joined
·
15 Posts
So I have the same problem, I've read that the earth's from the battery can cause problems if corodied one under the battery to gear box and one earth to body, well there's another two. If you use a jump lead negative from the battery earth it to the body and see if it runs better. Also fuel volume regulator control circuit open, a bad earth or command from the ecu to that circuit give's an incorect pressure to the fule rail and the censer tells the ecu to cut the engine. This is why the engine peaks and toffs. As fare as I can tell .... problem is bad earth? SOMEWHERE broken ecu... or problem with fuel volume regulator. Or bad battery maybe. This is more common than you think, but no one has an answer people have changed the ecu and great, for a month then it's back to squ 1.... god knows
 
1 - 9 of 9 Posts
Top