Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey team

My 07 207 gt (1.6thp) has developed some issues,
1.Dip headlights wont work, bulbs ok, fuses ok, dip light comes on on dash. Is the dip headlight relay in the engine fuseboard? (the rest of the lights work includling light height adj)
2.Door locks lock/unlock at random, this is pain but not a failed warrant of fitness
3.Fuel gauge fluctuates dramatically at random

2 and 3 are minor, 1 is a real problem.

Additionally, the turbo oil line leaks(and looks a pain to change), power delivery is all over the place and fuel economy is poor(im guessing one of the O2 sensors?, ive done a injector clean)

Thanks in advance,
 

·
Registered
Joined
·
2 Posts
I have unsolved probs with mine. Can't help with 1 and 2 but for 3 reset the ECU (remove and replace the yellow No 1 fuse in the box by the battery). I get the "Depollution system faulty" all the time, rough idle/starting and heaps of codes. When it gets too bad I do the reset and it's OKish for a while. After one time the l/km went berserk, then a few times later it came good again. I'm looking for a good mechanic, I'm 500 km from a dealer, then 3000 to the next one. My usual bloke locks the gate if he sees a Peugeot coming. I haven't had the 207CC GT long. It was overfilled with oil when I got it so maybe that was the beginning of the code storm. It's a 07 build with only 42000 km. A Roland Garros, with a split personality. Ideas welcome.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I have unsolved probs with mine. Can't help with 1 and 2 but for 3 reset the ECU (remove and replace the yellow No 1 fuse in the box by the battery). I get the "Depollution system faulty" all the time, rough idle/starting and heaps of codes. When it gets too bad I do the reset and it's OKish for a while. After one time the l/km went berserk, then a few times later it came good again. I'm looking for a good mechanic, I'm 500 km from a dealer, then 3000 to the next one. My usual bloke locks the gate if he sees a Peugeot coming. I haven't had the 207CC GT long. It was overfilled with oil when I got it so maybe that was the beginning of the code storm. It's a 07 build with only 42000 km. A Roland Garros, with a split personality. Ideas welcome.
So my issue lies with the BSI which controlls all of the parts that have issues on mine, to replace has been priced at $1k NZD (the car is only worth 3) to replace with a secondhand one and recode to work with the BSM and immobiliser. Im trying the BSI reset as posted on here but not having any luck.
Mine had a depollution system alarm when i bought it, i bought a OBD2 wifi plug for $12 and reset it while also replacing the boost controll solenoid (all of the rubber was missing out of the original one, the three allen key bolts on the side of the turbo) which fixed the issue. Good luck, i wont be buying another french peice of shit.
 
1 - 4 of 4 Posts
Top