Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
Hi guys,I bought a peugeot 207 Gt 150 model a fww months ago and I must say that it`s a really nice car to have.All nice and smooth till a few weeks ago when depollution sistem came up.Since then the car is lumpy at idle,never had the same power and does a really ugly rattling sound when cold.I spoke with some mecanichs and all of them telling me different stuff and I don`t know what to belive.I was reading forums about this issue people have with this engine and I got a bit dissapointed because I couldn`t see any of them solved.
Everyone was saying that they replaced a lot of stuff and the car did the same after a while.Please guys if u had this experience share your toughts with me,maby somehow I can solve it and share the solution with you.I have a video of the engine running morning when cold and also have the full service history+every invoice of what was bought and changed on the car.
Thanks a lot for your time reading this!
 

·
Registered
Joined
·
4,785 Posts
Hi guys,I bought a peugeot 207 Gt 150 model a fww months ago and I must say that it`s a really nice car to have.All nice and smooth till a few weeks ago when depollution sistem came up.Since then the car is lumpy at idle,never had the same power and does a really ugly rattling sound when cold.I spoke with some mecanichs and all of them telling me different stuff and I don`t know what to belive.I was reading forums about this issue people have with this engine and I got a bit dissapointed because I couldn`t see any of them solved.
Everyone was saying that they replaced a lot of stuff and the car did the same after a while.Please guys if u had this experience share your toughts with me,maby somehow I can solve it and share the solution with you.I have a video of the engine running morning when cold and also have the full service history+every invoice of what was bought and changed on the car.
Thanks a lot for your time reading this!
http://www.peugeotforums.com/forums/introductions-28/brief-faq-guide-new-members-83170/
 

·
Registered
Joined
·
47 Posts
My thp150 used to rattle when cold. It was the dreaded timing chain, tensioner and guides. Its an engine out job. I was quoted £700 by arnold clark. Its a real pain in the ass but since then its ran well. Only other fault I had that caused a drop in power was the turbo coolant pump. Anyway, since the timing chain was fixed its ran smooth. No rattle on start up.
I'm just guessing though. If you want to be sure you'll need to contact someone with the diagnostic equipment.
Do you have a warranty?
 

·
Registered
Joined
·
65 Posts
Discussion Starter #4
hey Stevie!
I just contacted someone with a diagnostic tool and got the diagnostic done,here is what I found out!
P2262
P0299
P1339
P2261
P0113
P0238
I asked my friend google about them but there is nothing for sure..only for p1339 which is a cylinder nr3 missfire,I replaced spark plugs and diagnosed the coils but the coils seemed to be ok
 

·
Registered
Joined
·
36 Posts
Try putting good fuel in like nitro unleaded. I had a similar fault and told to try that and bang, 10 miles later the car was fine and I've never had a problem since with that fault. Worth a try buddy
 
1 - 6 of 6 Posts
Top