Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1 (Edited)
Yes, another one! 2007 110 Hdi

I pulled up from work the other day and the car was as normal.
Went to it an hour later and started it, and the ESP/ASR fault came up on the screen instantly.
The ABS light is NOT on, the speedo works, no power loss, the brake lights work as normal, the braking seems normal. Everything works as it should apart from the ESP error on screen and the ESP button lit up.

I've purchased a lexia 3 this week and run diagbox (7.02),
Its picked up a TPMS error (n/s/f doesnt have a sensor)
and its saying 'unrecognised ECU' for the ESP
If i go into that part it gives me a choice, and i can select type xxxxx70 ?? and then displays a C1301 fault. Do I trust this, as Peugeot have just quoted £1100+VAT for the part. and £50+VAT for their diag, which will probably come back with the same.

Anyone have any ideas I can test?
Also, any version of diagbox that would connect properly?
And which menus to disable TPMS?

Many thanks
 

·
Moderator
Joined
·
12,149 Posts
Take out the engine bay fuse, spray with electrical contact cleaner.

Check connections on ABS unit.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
I've just tried running Diagbox again, then PP, then DB...
And with the occasional 'Braking System Faulty' alert popping up, this time it has actually recognised the ESP/ASR/ABS as ESP_MK60 and straight to an error code: C1301 - Braking Pressure Sensor Signal.
Cause: Local
Status: Permanent Fault
Chars of fault: Coherence

Googling the Teves MK60....... Oh F*&K.....
I knew there was quite a few people having problems, but why havent these units been recalled or even banned????

I have seen ECU Coding for replacements/recons, but there is supposedly an external fix?? Does anyone know about it?

Also, If I were to buy a replacement, would it need to be coded, and how would I go about it......without going near a Peugeot garage?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
Peugeot have diagnosed the fault as the ABS/ESP pump

The warranty company wont pay the dealers price, and I dont blame them.
They have suggested 'Lynx Automotive' as having a recon unit for a lot less. I think my local garage would fit and bleed the system, but they arent able to code the pump if needed.
What is actually involved in coding/recoding the unit?
I have a screen shot of what is displayed in PP2000/diagbox under the ABS/ESP tab. Is it just copying the values over to the new one?
Could anyone post what their values look like to see if mine are similar?
Any help would be really appreciated.
 
1 - 4 of 4 Posts
Top