Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Help!!!
My car had been down for months. It won't start. A mechanic checked it out and ran a diagnostic on it said it was the crank sensor. Changed the crank sensor, still no start. This time the windows and light didn't work. Another mechanic checked it out and said it could be a faulty fusebox as these go bad also he said the ECU appears to be locked. I replaced the fusebox, windows and lights started to work again, crank no start. Another mechanic came and was able to communicate with the ECU and cleared some codes but some remained unable to be removed. (See attached pics) we've replaced spark plugs but not getting any sparks and fuel pump is working. I've ran out of ideas. when we crank it seems like it wants to start but never does. I don't know what to do again. Oh one more thing under the fusebox where there are large fuses was literally under water. Can anyone give me advice on what I should do again or what steps needs to be taken in getting this car fixed
 

Attachments

·
Registered
Joined
·
2,475 Posts
It is almost certainly water ingress to the ECU and/or wiring harness(es) connected to the ECU. I fear no cheap easy fix.

Perhaps you could remove and open up the ECU, and use iso-propyl alcohol (propanol) to clean and dry it, checking carefully for corrosion. If corrosion is severe, the ECU may have to be replaced. Also inspect all the connectors and cable end connectors and clean with electrical cleaner spray
 

·
Moderator
Joined
·
6,281 Posts
Have you done the simple things like beep test incase key code has been lost

Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
15,377 Posts
Yep lools like the well documented water ingress issues these suffer from but before condemning ecu have you done the beep test ?

If its not beeping it wont start and when the ecu is locked it tends to be hard to clear fault codes.

IF you decide to change the ecu you need a complete ecu set this consist at minimum the ECU the BSI and the key these 3 parts are the important part but you can also get the instruments as mileage is stored there so replacing is going to alter the mileage.

Dont just buy an ecu as it wont work unless you know someone who is able to decode and recode to your car also the wiring on the engine may be the source of the issue so you may need a loom too and new temp sensor and washer pump sounds daft i know but its true water gets in from these 2 things !
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I've tried the beep test. The car beeps when the key is left in the ignition and the door is opened. So I know the key code hasn't been lost. I checked for corrosion on the ECU pins and saw very slight on one of the pins. (See attached pics) i used the electrical contact cleaner on the connectors and ECU pins. But still it won't start it cranks almost starting and stops after a while. But I was thinking since I've changed the fusebox I probably need to chanced the wiring that goes to it. (I'm not an expert in car electricals so correct me if I'm wrong). Please share a link where I can purchase it. I'm just frustrated as to what to do again. I really don't want to scrap it. This problem began when I left the car out the garage one night got up the next morning and it started and cut off. It was started again drove for about 100m and cut off again, that was it
 

Attachments

1 - 5 of 5 Posts
Top