Peugeot Forums banner
1 - 3 of 3 Posts

·
Registered
Peugeot 207 1.4hdi 2008
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi!I have this car for about 5 months,it started to cut out(or maybe it is stalling) since day 1.First only when engine got warm,only at traffic lights,junctions,stop.Then I was driving at about 40-50 km/h,and it cut out again.eml on,antipollution faulty.changed lot of parts,fuel filter,iat sensor,egr valve,no luck!Diagbox shows egr related errors,P1113 error(diesel high pressure monitoring),etc.I replaced the egr valve,cleared the error codes,no eml or antipollution.Next day I had to go to technical inspection,started the engine,eml on,antipollution also on,without moving the car from the day I cleared codes.I am suspecting that the P1113 error could be the issue,because I had 5-6 error codes,I cleared the P1113 error and another 2 or 3 errors disappeared.
Computer Personal computer Font Display device Software
Rectangle Font Gadget Display device Electronic device
 

·
Moderator
Joined
·
9,857 Posts
Some 1.4/1.6 hdi and ecu combinations (can find my notes at the moment) have an issue with the EGR valve.

When it starts to fail it generates an internal electrical short circuit which kills one of the ECU power supply rails which stops all the sensors on that rail working.

I think its fuel pressure sensor, air temp and mass and a few others so worth checking

Sent from my SM-T830 using Tapatalk
 

·
Registered
Peugeot 207 1.4hdi 2008
Joined
·
17 Posts
Discussion Starter · #3 ·
thanks for reply.air temp sensor was replaced,if it's about in take air temp sensor.also,I will check in the morning the fuel pressure sensor and also the fuel regulator.ecu power supply rail?is it bad?
 
1 - 3 of 3 Posts
Top