Peugeot Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Driving with no problems. All powerlost. Engine wont turn over, connect slave battery engine starts. But with seatbelt, abs and battery light on. Drives ok all lights off after a few minutes.

This scenario repeats itself ad nauseam. When running all lights are out.

Help
 

·
Registered
Joined
·
15,122 Posts
Ok your initial post is not very clear can you tell us better what is actually happening NOW instead of drip feeding more info in each post

You say new battery does car now start with said new battery or do you still need a booster battery to start ?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
Full story. Engine stalled. All lights on. Battery flat, jump started. Battery light on, battery flat.
Replaced battery, Warning lights out for 10 mins then n battery light on, not charging.

Replaced alternator, not charging battery light on sometimes all warning light. Replaced earth lead no change.
 

·
Registered
Joined
·
15,122 Posts
Ok your issue is either the alternator or the wiring to it there are different control systems used depending on age engine etc some are controlled directly by BSI some just fed from battery light wire could even be a fault in under bonnet fusebox as all signals pass through it.

Check the main power wire from the alternator sometimes they rot at the ends.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #10
Turned out that the new alternator was faulty. Pushing out 8v instead of 14v. All good now. Thanks for help
 

·
Registered
Joined
·
5 Posts
feedback

Well as the poster before has on his signature, Assume nothing, check twice.

Also good that you posted the feedback on your solution as this is important for others to learn too.......

Agree that when you fitted the new alternator (or whoever did) should have put a multi meter on the battery and checked what charge was being pumped into the battery, with and without lights etc.......
 
1 - 12 of 12 Posts
Top