Peugeot Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi i have a 206, 2008 model. My ABS light has came on, so with the handbrake light and air bag light. The Mileage is not going up too and so is the speedometer.. Could a failing wheel sensor cause all these ? I have a multimeter, but i have no idea whats the resistance required, how to even check if the wheel speed sensor is working! I hope some one can help me :)
 

·
Premium Member
Joined
·
2,143 Posts
Have you checked the ABS system fuses?

You mentioned both the speedo & mileage not working - that points to the ABS unit being at fault.

You need to get the ABS system fault codes read to see what errors are present.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I have no idea where the ABS system fuse is..is it at the engine bay or below the instrument cluster?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Have you checked the ABS system fuses?

You mentioned both the speedo & mileage not working - that points to the ABS unit being at fault.

You need to get the ABS system fault codes read to see what errors are present.
The codes i am getting is that the vehicle speed sensor is out or range or erratic. but thats the DTC code, i am not able to get the ABS codes
 

·
Registered
Joined
·
585 Posts
What's the exact DTC code? That sounds like the ABS module complaining about one of your speed sensors.
 

·
Registered
Joined
·
585 Posts
P0501 is a Powertrain code for the speed sensor. There's a speed sensor in the gearbox that's used to calculate speed etc, that might have gone bad.
Which engine type do you have and which gearbox?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
P0501 is a Powertrain code for the speed sensor. There's a speed sensor in the gearbox that's used to calculate speed etc, that might have gone bad.
Which engine type do you have and which gearbox?
Its a TU3 1.4L electronic multipoint injection with the tiptronic 4-speed auto gearbox.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
P0501 is a Powertrain code for the speed sensor. There's a speed sensor in the gearbox that's used to calculate speed etc, that might have gone bad.
Which engine type do you have and which gearbox?
would the code be different if the ABS pump had failed? Cause the ABS pump failure has similar symptoms to what i am experiencing right now.. Thanks
 

·
Registered
Joined
·
585 Posts
The U codes you have are bus communication ones. So you need to get the wiring checked out first before you consider the module. How are you reading the faults? Using PP2000?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
The U codes you have are bus communication ones. So you need to get the wiring checked out first before you consider the module. How are you reading the faults? Using PP2000?
nope i am using a elm327 and the car scanner application
 
1 - 14 of 14 Posts
Top