Peugeot Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
I'm from Brazil, new to the forum....

This week I'm searching everywhere for a possible solution to this problem.
Mine is a 205 1995 1.4 XSi petrol.

I've already changed:
- TPS sensor for a electronic one, adjusted with a multimeter as the manual said;
- fuel pressure regulator diaphragm, the old one was very worn;
- fuel pump was changed by the old owner before me

When I'm driving and the car reaches 2k rpm in every gear, it start to misfire and look like it's with a rich mixture.

After this rpm the car runs normal, good torque and normal acceleration.
Idling is very low on the other hand and already ordered a new idle control sensor.

If I hold the gas in 2k rpm without any gear, is starts oscillating rpm from 1.8k~2.2k by itself.

What should I look for? Electrics, fuses, wiring harness?

Thanks
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 · (Edited)
here is a video of the trouble...

youtu.be/fu2zEXBLHew (can't post links because my post count is low, if anyone can help, tks)

at 2k rpm and steady throttle the engine starts fluctuating revs
with a polarity tool it's possible to see that the current in the wire represents the issue of cutting the injector signal

maybe a problem with the ECU? or the FET?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Solved

I've bought a new idle air control valve and solved the issue.
It's only 3 torx T25 or T27 to change it, use a socket because there's little space there.

The ECU uses de idle air control to set the cut-off mode, but mine was broken and always telling the car (idle control fully in) that I was always in cut-off.

Now there is no misfiring (cut-off in fact) at 2000 RPM and it's driving normally!!!

It was a suggestion of one friend at Vieux Peugeot (Brazil) forums.

Hope this information can help someone else.
 
1 - 3 of 3 Posts
Top