Peugeot Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hi all.
I am based in Melbourne, Australia.
I have a 2014 Oct build Allure (petrol turbo 1.2)
I bought it brand new in October 2016 (assuming it was in the docks for 18 months or so).
Lovely car, however have had some minor niggles here.
Posting this recent issue.
Radio static - Literally since the day I bought the car I have been intermittently getting 'static' or muffled distortion when listening to mainstream radio stations.
There seems to be no distinct pattern as to the where and why. When reported to my dealership service dept, they asked the usual questions about whether it was in a rural area (negative - occurred in the Melb CBD, inner suburbs, and has been clear in rural areas). Is the music settings irregular? I have played around with various settings, bass, treble etc....again, no pattern
It's a nuisance and one the service dept has tried to address by 'replacing a magnetic bracket'. This didn't resolve the issue.
I have now had the vehicle almost 8 months, and I believe the issue is logged with Peugeot to which they are awaiting a resolution.
It's not ideal at all - I am not a music aficionado but goodness, you would expect a quality European car, brand new, in this day and age to have a very engaging level of quality when it comes to sound. I have driven cars 15 years older than this (Toyota, Mazda etc) that have the original stereo's and speakers and doesn't miss beat.
If anyone else has had this issue, would love to hear and also how you came to a resolution. I have asked my service dept around whether it's the antenna, but hey....I am not the expert.
Cheers, and thanks for your time.
Sarj
 

·
Premium Member
Joined
·
3,343 Posts
The antenna would be my first port of call. There is an amp in the base so hopefully it is getting the 12v supply. Secondly when I had this problem - on an older 307 admittedly, changing the whole aerial base and whip sorted it. I then took the old base apart and found corrosion in the slightly sprung contact between the antenna and the amp PCB. The later one night not be the same internally, but it looks the same externally.
 

·
Registered
Joined
·
1 Posts
Problem 1- fm/am radio reception in Aus especially melbourne is shocking. This is why DAB was invented!

Problem 2-Dont drive in CBD areas and expect to get crystal clear reception. You are living in a dream world! Intereference is everywhere!
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
Problem 1- fm/am radio reception in Aus especially melbourne is shocking. This is why DAB was invented!

Problem 2-Dont drive in CBD areas and expect to get crystal clear reception. You are living in a dream world! Intereference is everywhere!
Hi there mate. Thanks for the response. Sure, I can appreciate some areas having not the best reception, however having driven many, many vehicles over the last 20 years or so I have reason to be believe I would be a fairly decent judge of whether my current vehicle is above-and-beyond normal interference experienced here in Melb (and surrounds).
Lucky enough I had recorded a number of the occassions this had occurred and am sending through to my dealership. I have a 2012 Ford Focus that hasn't missed a beat when it comes to reception (as does my partner's 1990's Mazda Mx5!)
I have had other issues with the console, such as over-heating (in cold weather). Not sure if it's at all related but keen to get to the bottom of this before dare I say my warranty expires!
 

·
Premium Member
Joined
·
3,343 Posts
Clearly if this car is bad compared to several others in the same places, then it's the car.

Do you have access to any Peugeot Customer services over there? They were helpful to me when I had a radio (DAB) problem.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #6 ·
Thanks mate. Yes, I have reported it several times to my dealership (where I purchased the car new from).
Unfortunately, each time they have had it they haven't replicated it.
I have it escalated to the Peugeot Australia customer service, and well it's been a frustrating exercise - I 'have' to demonstrate it or the dealer must be able to replicate before they can look at possibly replacing some things. Luckily I recorded/documented several occassions on my phone and have sent them the video's. Am just waiting to see what they come back with.
Considering the lack of responses I got through the forum so far I am guessing it's not "common" .
Cheers
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top