Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all, I've recently purchased a Partner crew van with 75k and lots of good service history. Not had a Pug van before, coming from 1.8 Ford Connects previously, I know little about the Hdi engine.. anyway, my problem is this..
It runs sweet as far as I can tell but today I booked a reputable remapping guy to work his magic to unleash more power from the stock 90ps engine. When I tested drove it after the van was hesitating around 2250 revs in 3rd/4th/5th gear under load. The guy said he thought it was the turbo boost pressure dropping and this showed up on his screen plugged into the diagnostic port in the van while I drove it. So something causing the boost to drop intermittently. He returned the ecu to standard settings and it now drives as before with no hesitation.. either that or its just hardly noticeable with less power/pressure going through the turbo? Having read all the 1.6 Hdi turbo issues this has worried me. Any idea if this signifies potential turbo failure or could it be (clutches at straws) something simple? I would love to get this sorted and keep the van as i really like it in all other respects.
Your experience and wisdom would be appreciated
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
.. I meant to add that there's sometime a smell of fumes in the cab too.. injector seat washer? would that have anything to do with it? Remapping man noticed some gloop around number 1 injector but said it wasnt leaking.
 
1 - 2 of 2 Posts
Top