Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1
Hi have in a 2009 E7 taxi in with 2.0 HDi engine RHK only done 81000miles

Customer said the turbo went and the engine had run on its own for a bit...!

Anyway he had a garage fit new turbo and one injector..!

I have had it in to try and cure the black smoke it emits under load its like a red arrow but bellowing black smoke.

There are no faults on ecu at all...!

Took intercooler off and drained the oil out etc....!

egr valve working in live data etc...

I think maybe damaged engine internally !

Any ideas please ?
 
D

·
Guest
Joined
·
0 Posts
Do a compression test. Also why was there an injector changed?

Sent from my GT-S5690
 

·
Registered
Joined
·
94 Posts
Discussion Starter #3
Thanks for that

Dont no why was changed he wasnt very clear...!

Not got a diesel compression tester !

There is no misfire and he never mentioned it lumpy or rough when starting from cold..The engine does breath if you open the oil filler.

Its like proper soot as if not fueling properly but boost etc and airflow are all good.

Have you come across this before ?

Thanks David
 
D

·
Guest
Joined
·
0 Posts
Remove the egr valve also and inspect. The end caps tend to break off them.

Sent from my GT-S5690
 

·
Registered
Joined
·
15,377 Posts
Mileage is a bit low for a turbo failure to be honest has it been well serviced we had 1 of ours blowing lots of smoke but it had 150k on it still on its original turbo in fact still is now and its getting close to 200k :)

Ours was smoking due to worn rockers no real noise from them but after stripping it down they were obviously well worn out a new set and it was good as new again

If yours is poorly serviced they could have worn even sooner especially if it reved its nuts off while drinking its own oil :)
 
1 - 5 of 5 Posts
Top