Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi All

I've bought a 307 SW with light front end damage, the front airbags were deployed in the accident. I've replaced the dash with passenger airbag, airbag module, seat belt pretensioners and drivers airbag but the light is still on.

I've also replaced the COMM2005 unit and drivers airbag again with known good items. Done a BSI reset, cleared codes with Peugeot Planet but the light comes straight back on. The fault in Planet is;

AIRBAG ECU
Level 2 driver/Es air bag fault . High Stop . Local

All the associated wiring under the dash looks fine and I'm at a loss at what to look for next, any ideas please?

Thanks in advance
Andy
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Actually something just occurs, the airbag kit I got for the initial replacement had a 2 plug drivers airbag where my later car has a single plug. Even though the airbag ecu has the exact same part number I now suspect they are programmed differently.

Next step has to be to try another airbag ecu.
 

·
Moderator
Joined
·
6,000 Posts
You should be able to reconfigure airbag ECU with planet

Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks, I've had a quick google and I think that procedure needs the PIN code on a card that comes with the car (I don't have that).

I do have Planet though so I'll have a look over the weekend to see if I can figure it out. I've ordered a later airbag ecu anyway so either way this will hopefully sort it, I'll post up results.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
You should be able to reconfigure airbag ECU with planet

Sent from my SM-G965F using Tapatalk
Spot on! :thumb:

Went into Planet and set the level 2 drivers airbag to "Absent" and the light went straight out.

Thanks for the pointer, I've now got a spare COMM2005, Drivers Airbag and Airbag module as spares :lol:
 
1 - 5 of 5 Posts
Top