Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello Everyone ( Hopefully)
First post, Here we go. Last night driving home and bleep and battery light came on, Message displayed INFO Electrical circuit fault, Turned headlights to side lights and it went off after a couple of seconds. Turned headlights back on and everything ok for a minute or two then same again. Again repeated the process and again it went off so I decided to finish the journey on side lights. Just as I reached home again it happened but this time it has stayed on.
Recently had a new clutch and flywheel fitted and this is the first time that I have driven at night since then with wipers ,blowers etc going due to rain.
Could there be any connection or am I looing at a high percentage that it will be the alternator ? :confused:
Thanks
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
hello everyone ( hopefully)
first post, here we go. Last night driving home and bleep and battery light came on, message displayed info electrical circuit fault, turned headlights to side lights and it went off after a couple of seconds. Turned headlights back on and everything ok for a minute or two then same again. Again repeated the process and again it went off so i decided to finish the journey on side lights. Just as i reached home again it happened but this time it has stayed on.
Recently had a new clutch and flywheel fitted and this is the first time that i have driven at night since then with wipers ,blowers etc going due to rain.
Could there be any connection or am i looing at a high percentage that it will be the alternator ? :confused:
Thanks
update on the above
went out this morning started first time ( not quite as quick turn over) ran for about 2 minutes thenbattery light on again and now it has abs light on .stop warning light on. The messages are unreadable as they are in french ( i presume). So stopped the engine and then tried to restart but nothing totally flat.
Connected multi meter and the battery is showing 15/16 volts ?
Can't get my head around this ! Any suggestions please ?
 

·
Registered
Joined
·
548 Posts
Check all the earth straps/points.
Check voltage while someone attempts to start the van.
If you have a known good battery you could try that or a trip to the nearest tyre & battery shed, they should be able to test battery & alternator output.

It does sound as if its one of the three so hopefully easily sorted. Peugeot's tend to through out all sorts of messages when the battery level is low.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Storeman, Excellent advice, sounds a good possibility since the gearbox has been removed 4 days ago to replace clutch and flywheel. I'm pleased that I found this site as I wasn't expecting a reply so soon. Thanks again everyone. I will update if and when fault found
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Update

Hello again,
This is an update for the problems that I listed. Booster pack attached and she started straight away as normal. According to breakdown recovery everything was ok but battery was low and he thought that maybe a battery check would be the order of the day and off he went. Left it running for about 35 mins and then drove 10 miles to my local garage that normally do my repairs. She again started under own power without assistance and ran ok so mechanic checked charging current which was ok but if loaded would be insufficient and eventually kill the battery as it did during Saturday night when we had a bout of heavy rain . So it looks like an alternator replacement and the battery has escaped any damage.
Morale of this story is check everything twice and don't take the first opinion that you are told, Even from a recovery person !
cheers to the 2 members that gave their valuable advice it was nice to have help.
 
1 - 7 of 7 Posts
Top