Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hi I have had this car for a week and everything was fine. On New Years Day in the early hours the power suddenly dropped, but managed to limp home. There are no lights on the dash and the computer isnt displaying anything. I have driven this today without much problem apart from going up inclines where it struggles but gets there, but wouldn't like to take it on a motorway.

Having researched this it seems to be a common problem, solutions including cleaning particulate filter, cleaning pipes to turbo, checking for holes in pipes, new turbo solunoid amongst many.

Can anyone suggest the best order to try solutions in, and anything else I should be checking? Thanks
 

·
Registered
Joined
·
481 Posts
I find it strange that you don't have any lights on and the car in limp mode.

When you put the ignition lights on without starting the engine do you have a yellow engine symbol (the engine management light) ? and if so does it go out when it should? (a few seconds after starting the engine)

I have just repaired a car where someone has put silicon sealer in the clocks to mask the engine management light!
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
Hi Thanks for the reply. I don't know if it is actually 'limp mode' as such but its down on power, the turbo doesn't feel like its working but theres no warning lights on.

Have booked in for a diagnostic check thursday. Will check what you've mentioned above when I get home.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #4
I find it strange that you don't have any lights on and the car in limp mode.

When you put the ignition lights on without starting the engine do you have a yellow engine symbol (the engine management light) ? and if so does it go out when it should? (a few seconds after starting the engine)

I have just repaired a car where someone has put silicon sealer in the clocks to mask the engine management light!
there is a yellow light shaped like an oil can and it goes out when I start the engine, if thats what you mean.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #6 (Edited)
Ok so took it to the Peugeot specialist who says he thinks the spindles snapped in the turbo. The annoying thing is now its got the anti pollution warning AND the engine light on all the time, neither of which were there before!!!

OH is quite good with anything mechanical and my dad has always got engines in bits.

edit: just driven home and now no ap warning or engine light on!!!!!!!!!!!! Is it normal for these to keep going on and off please?????
 
D

·
Guest
Joined
·
0 Posts
Ok so took it to the Peugeot specialist who says he thinks the spindles snapped in the turbo. The annoying thing is now its got the anti pollution warning AND the engine light on all the time, neither of which were there before!!!

OH is quite good with anything mechanical and my dad has always got engines in bits.

edit: just driven home and now no ap warning or engine light on!!!!!!!!!!!! Is it normal for these to keep going on and off please?????
Be prepared for an engine. The sump NEEDS to be removed and checked for carbon buildup!
What is your servce history like and what grade oil has been used?
 
1 - 8 of 8 Posts
Top