Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2.0 HDi 136 has intermittent problem with acceleration, can be happily driving along when the car starts to decelerate, when pressing the accelerator pedal nothing happens :(
If I dip the clutch its ok again and continues to accelerate with no probs, any ideas?
Have plugged in planet but no faults codes present and as its intermittent won't replicate when plugged in. Have a suspicion it may be related to fuel pump pressure regulator.

Thanks :thumb:
 

·
Registered
Joined
·
114 Posts
hi

hi had same problem last week, gave it a shot of millers ecomax £13 one day later all ok. runs great give it a try . danny:lol:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Please excuse my ignorance but how will this help? Car generally runs without missing a beat, no smoke, no particulate filter issues.
When car fails to rev pressing the accelerator does absolutely nothing at all, the fault can be a week apart without re-occurring so suspect sensor or electrical..
Thanks for replies
 

·
Registered
Joined
·
1,073 Posts
Mine has a faulty electrovalve to the IC bypass throttles, so during DPF regens it would close the regular one, but not open the bypass one. This happened usually on partly throttle, idle and wot was still working. No fault codes though. Also only happened once a week when car tried to regenerate the DPF. Somehow it seemed like it was able to do the regen, but part throttle could not be used, then it just was like someone shut down the throttle totally.

I suspect if it was the fuel pressure regulator you would get some codes on low pressure?

You can try to take off both vacum lines to the bypass throttles, and block them with some suitable sized object, at least just to eliminate it.

I never changed the electrovalve though, just put some ball bearing balls into the pipes so nothing happens anymore when they try to activate :)
 

·
Registered
Joined
·
1 Posts
2.0 HDi 136 has intermittent problem with acceleration, can be happily driving along when the car starts to decelerate, when pressing the accelerator pedal nothing happens :(
If I dip the clutch its ok again and continues to accelerate with no probs, any ideas?
Have plugged in planet but no faults codes present and as its intermittent won't replicate when plugged in. Have a suspicion it may be related to fuel pump pressure regulator.

Thanks :thumb:
Got the same car and its not revving but can iddle wat can l do?
 
1 - 10 of 10 Posts
Top