Peugeot Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello, new to this forum. There's a Peugeot 406 with a transmission problem, in short, sometimes D and P start beeping, the dot next to them too, at the same time. It drives normally just beeps, it's also not consistent. The fix found was turning off the car and starting it again.

Next recent problem that it started not accelerating when taking off of a stop-light, even if you push the gas it doesn't "register" it. Sometimes cutting off power for a second then coming back on normally. It isn't consistent and happens once in a while.

I don't know any codes for the tranmission, just wanted to know if it's a common known issue, if this is fixable, et cetera.

Short clip I have for the D and P problem, there's no evidence of the car not accelerating after a stop light/stopping.

 

·
Registered
Joined
·
120 Posts
Regarding if it's fixable, I'm sure it is if you can find the root of the problem. The only common issue of AL4 that I know of is regarding older electro valves (solenoid), the fix is by replacing them with Borg Warner solenoids. And I don't know if it's considered common issue or not, but many people are believing the "filled for life" fluid and then never did a fluid change until it's too late. Maybe other members could fill in with another known issues.

What engine do you have? If you want to diagnose your problem, the best thing to do would be to connect PP2000 / Diagbox and see what codes are stored. Regarding not accelerating after stop, if I had to guess maybe check throttle position sensor.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 · (Edited)
I know this is an old threat without updates but now I could actually drive myself so
  • The engine code is RHZ it's a 2002 2.0HDI engine with 80KW
  • So far when the dash started beeping (It's now not the P and D, but the snowflake and sun right next to it, the thingy where you choose what mode you drive in) it was either up the hill, when it downshifted from 4th gear to 3rd, on a straight when I pressed the gas pedal too much, it downshifted into 3rd and started beeping. Now I do not know if it started beeping because it downshifted, or downshifted because it started beeping, the car won't go to 4th gear anymore after and is in kind of a limp mode? The car doesn't accelerate well from a stop (I believe it's stuck in 3rd), takes a long while to do so, still can be fixed by turning the engine off and on. The next time I will purposefully try to get it downshift from 4th to 3rd under acceleration to see if it's consistent and update this thread further for now this is all I know.

    UPDATE : Now I checked the solenoid problem and it does say the snow or sport mode will start beeping and it's stuck in 3rd gear, so I will check into that further.
 

·
Registered
Joined
·
1,142 Posts
The only common issue of AL4 that I know of is regarding older electro valves (solenoid), the fix is by replacing them with Borg Warner solenoids.
This is what you need to check. You can do this easily by removing the side cover on the auto box and see what colour the top of the 2 offending electrovalves are. iirc the borg warner ones have a black top? If you do replace them, you need to get them recaibrated for them to work properly. Google will probably provide a how-to showing which 2 valves you need to check/replace.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
This is what you need to check. You can do this easily by removing the side cover on the auto box and see what colour the top of the 2 offending electrovalves are. iirc the borg warner ones have a black top? If you do replace them, you need to get them recaibrated for them to work properly. Google will probably provide a how-to showing which 2 valves you need to check/replace.
Oh thanks. What do I need to get them recalibrated? Specific software or just some diagnostics tablet? I will update post if I find it myself, thank you. Also I didn't find any Borg Warner solenoids so I just bought at least something for there, it wasn't too expensive for me and I don't think they are going to break again if they first broke only after 18 years.
 
1 - 5 of 5 Posts
Top