Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hi all! Fairly new here. I have a misbehaving digital clock/MPH/MPG/temp etc instrument. I've got a replacement one I bought off ebay, but am at a loss how to get at it!!
Can anyone out there give me a pointer how to go about this? I'm reluctant to charge in, prizing off panels without knowing what I'm doing.
Would very much appreciate any help.
Also, where the hell is the diagnostic socket located???
 

·
Registered
Joined
·
1,054 Posts
If it is the small rectangular display under the 3 round clocks you open the storage compartments on either side and undo the screws then lift it out. Note there are a couple of 1.2W illumination bulbs, check these.
Diagnostic socket is under the steering column, you have to be on your knees to see it.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
wynb - thanks very much for that! I'll get on to that 1st thing tomorrow. Many, many thanks.
Clive 1939.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
wynb : Well, I've replaced the unit, following your instructions (thanks again), but it didn't resolve the problem. When I bought the car (2 years ago) the unit displayed 'MPH' in real time. After a run, before switching the engine off, it displayed the average MPH.
I thought that was great, especially as 'MPH' didn't seem to be available via the options on the unit!!
Then, a couple of weeks ago it displayed '12 mph" permanently!
The replacement unit now displays '00-00-01' (also permanently).
Any ideas????
The car's great, and a pleasure to drive. It's obviously not life-threatening - just bewildering!!
 
1 - 5 of 5 Posts
Top