Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all!

I'm new here and was wondering if i could get a little advice about a problem i have, I recently bought a 2004 307 2.0 HDI, I've had it for about a month now and its been fine for the first 3 weeks, then suddenly i got a message come up on the display alongside a loud beep and a stop message on the dash - the display read Top up engine coolant. I checked the coolant and there was plenty in there ( just under the MAX mark ) After a few minutes the warnings all
ceased. Didn't do it any more that day....

The next few days it got progressively worse, Loosing coolant out the expansion tank, then topped it up, fine. All warnings gone again.

Basically, i just thought maybe the Cap on the expansion tank was faulty, as i think its pressurized the parts in the middle of the cap were very loose, replaced that, ( and i know that when there's excess coolant and it gets to hot it leaks out through the side of the cap. ) - but please correct me if i'm wrong. Also topped it up. Fine, no more beeping.

Next day.. Surprise surprise it's beeping after 5 miles now and no more leaking signs around the cap but it's still beeping. All topped up, new cap.... It's not getting in the head gasket, the radiator isn't leaking, I thought maybe it's the sensor for the tank....?

Thanks for reading and any help is appreciated !


Cheers

Henry :thumb:
 

·
Registered
Joined
·
1,860 Posts
Hi Henry

A few thoughts you mention water not getting in head gasket, what about gas passing the gasket pressurising the coolant. I have a 1.6 that has a bleed valve near the heater pipes does yours need bleeding. If air lock in system the air would expand and push water out. Is the temp gauge correct not overheating, thermostat ok.

Just a few thoughts,

Allan


Sent from AutoGuide.com App
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi Allan

Thanks for the quick reply, The temp gauge is working fine, i'll have a look at the bleed valve later on, now you mention it, there was bubbles in the coolant return on top of the Tank going back into it.


Cheers

Henry
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Thanks Gibbo,

I'll check the gasket after work see if it's any good, the wires connected to the sensor do look a little rough, maybe i could clean up the plug a bit... See if it helps.

Cheers

Henry
 

·
Registered
Joined
·
3,426 Posts
was the cap the same one that you brought. ive seen some funny ones on 307s.

a few scoots ive owned in the past have had the coolant caps changed to be able to cope with more pressure as they used to piss coolant out of the side lol

if you havent had the car long might be worth bleeding the coolant and check its not dragging air in from somewhere
 

·
Registered
Joined
·
3,426 Posts
are you saying you top it up way max to get the beeping to stop. thus meaning its leaking coolant out of the cap?

if thats the case and it wont lose any water when at the max mark the sensors probably at fault
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
Cheers Monty


I'm going to check the Rubber gasket on level sensor, maybe bleed coolant in a minute.

When i fill it, it's only to the max mark, no higher. If it does turn out to be the sensor, i can get one for £13.50!


Cheers i'll let you know how it goes.

Henry
 

·
Registered
Joined
·
3,426 Posts
if your only topping up to the max mark and the coolants overflowing out the cap thats not right

both my cars are at max and both dont leak any water

if the level sensor is letting air in somehow could be an issue

i would rebleed the coolant. if not have you a 2nd cap to try?
 
1 - 11 of 11 Posts
Top