Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
we recently had the indicator switchgear fail on this car and it would not start, got towed to a garage and fixed with a new comms unit. the central locking now does not work, i read through different sites and the general opinion was try bsi reset and keyfob resynch, i have done both of these and still no rcl working the central button on dash also not working. am i right in thinking the fob needs recoding to the car now, and what would be the easiest and least expensive way to fix this issue please.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
the comms unit was a valeo 251499 that has the same function as the car local peugeot dealer isnt that interested tbh i can live with manual locking mrs likes the remote option. i have read about the bsi loseing the remote code and was hopeing it may be relatively straightforward but does not seem to be the case. thanks for reply trustme.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
it was brand new although i dont know what diagnostic kit the garage uses it used to be snap on with different cards /keys put in depending on vehicle i think. they originally diagnosed it as no comunication to comms but we took it back when we realised the the locking did not work and the answer from them was that only peugeot could sort it, and after visiting the local dealer and speaking to the service guy he never had a clue or interest in helping out in any way and a 2013 car was not worth fixing anyway in his opinion as it was beyond its working life time. even with 170k miles on it it still starts and drives okay everything else seems fine on the car as well.
 

·
Registered
Joined
·
4,779 Posts
Have you or the garage still got the original comms unit if so then just unplug wires and plug them in that one and try it and if works you know it's defo comms unit and have just proved it to garage

They broke it they should fix it end of
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
i am not sure what was done with old comms unit is it the comms that reads the plip key both keys work starting etc and the key in ign sounder works still. i am not 100% on the electronical bits fine with mechanical stuff and when the comms packed up the central locking was not working after that. the central display read eco mode and the mil light was displayed on instrument panel. also the radio lights indicators wipers etc were not working but the elecric windows did. i took battery off it and charged it refitted and tried sidelights and the doors i had locked manually unlocked but would not do anything on the remote, i think the locking issue was there before the car went to the garage. thanks for all your help i am a bit flummoxed what way to go really the local peugeot dealer does not inspire me to use them anyway and as i understand it needs peugeot kit to read and diagnose properly.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
thanks for your comments and help trustme i guess i need to get a check done on the diagnostics with someone with the right kit and knowledge to read the car properly. i did read somewhere about the bsi forgetting or loseing the remote plip code and needing reprograming in, and guess i was hoping that may be the case here.
 
1 - 9 of 9 Posts
Top