Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
I've been getting a lot oil in my expansion tank. Turns out, oil is getting into the water pipes on the cooler, as when I pulled the pipes off, dirty water came out, followed by oil.

What could cause this problem, as I have had headgasket failure symptoms, so I need to make sure if it is definately the cooler....
 
D

·
Guest
Joined
·
0 Posts
Have you checked the oil cooler. Its one place oil and water can meet.
 
D

·
Guest
Joined
·
0 Posts
It can also be a terminal engine problem eg a cracked head or block also. Change the oil cooler first and go from there.
 

·
Registered
Joined
·
14,297 Posts
Cooler does indeed cause problems sometimes we have had to change a couple its not hard and is easier than doing away with it to do away is possible but you would need parts from an older engine without a cooler not really worth it.

Join the 2 water pipes together and run it if oil comes out the pipe fittings then its holed and needs replaced.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
Well today I changed the oil cooler, connected everything back up, and on startup, I started losing all oil from behind the cooler??
So, with it being a brand new cooler, what could have failed or what could I have done wrong for it pass oil? The locating lug was seated properly?

Any help is appreciated...:thumb:
 

·
Registered
Joined
·
14,297 Posts
You may have no seal or put an extra seal on without realising and they are overlapping causing a gap remove it and check the sealing ring at the block face and make sure there is only 1 :)
 
1 - 10 of 10 Posts
Top