Peugeot Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Hi all, for the last month my car seems to be struggling until it reaches 2800-3000rpm. It takes a while to start some days, it has cut out on a couple of occasions while coasting with the clutch in. It has almost no pull with the throttle all the way down in 1st and 0-30mph takes a long time.

I took it to my regular garage and it won't connect to their diagnostics machine. I think it's the 2.0 HDI non turbo engine but here's a picture of the engine bay 20170406_144812.jpg

Any ideas on what the problem could be?
 

·
Registered
Joined
·
1,904 Posts
Really need it read on the pp2k system to find what's what. Either go to the dealers or try to contact a member of the forum who lives in your area to see if he will kindly read the car for you. There is a list of such good souls on the forum. Whereabouts are you as I have the system and will help if I can.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #3
Really need it read on the pp2k system to find what's what. Either go to the dealers or try to contact a member of the forum who lives in your area to see if he will kindly read the car for you. There is a list of such good souls on the forum. Whereabouts are you as I have the system and will help if I can.
Thank you for the reply. My local garage did try reading it but it wouldn't connect to the diagnostics machine. I live near Swansea in South Wales, if someone could that would be great, I wouldn't expect anyone to go out of their way for free though obviously.
 

·
Registered
Joined
·
170 Posts
Thank you for the reply. My local garage did try reading it but it wouldn't connect to the diagnostics machine. I live near Swansea in South Wales, if someone could that would be great, I wouldn't expect anyone to go out of their way for free though obviously.
Cibear is in swansea or there is Ayel is in cardiff they would be your best bet. There is s thread you can use to increase your post count to 20 to be able to pm them. just do a search and you will find it
 

·
Registered
Joined
·
14,581 Posts
ALL 2 litre HDI engines are turbo engines it sounds like some form of airflow issue but could be many things without proper diagnostics including LIVE DATA you will struggle to fix it

Codes are not much good on HDI engines they only tell you what HAS happened live data tells you what IS happening :)
 

·
Registered
Joined
·
55 Posts
Discussion Starter #6
Thank you for letting me know I will have a look. I took it for a drive today and got a engine light and anti pollution fault, it wouldn't rev past 3000rpm.
 

·
Registered
Joined
·
14,581 Posts
Ok next piece of useful info antipollution fault IS NOT a fault its simply a message its just peugeots way of telling you SOMETHING is wrong but you already know that !!

It does NOT have anything directly to do with your DPF which incidently you WONT have only 110 hp has a DPF yours is a 90hp so when the guy down the pub tells you its your DPF and you need to gut it and remap it you know he is wrong :)

Being a 90hp with siemens injection you do not have an in tank pump either so if anyone tells you thats whats wrong again they are WRONG.

Turbos rarely fail either.

EGR system issues and wiring issues are the most common reasons for problems other than self inflicted issues like dirty diesel or lack of servicing.
 

·
Registered
Joined
·
89 Posts
You need to check all the little vacuum hoses.
I had the same problem with mine. It is the RHS engine, slightly different from yours. But one of the hoses had a little tear, of course it was the one, that were hardest to get to.



Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
89 Posts
Hi all, for the last month my car seems to be struggling until it reaches 2800-3000rpm. It takes a while to start some days, it has cut out on a couple of occasions while coasting with the clutch in. It has almost no pull with the throttle all the way down in 1st and 0-30mph takes a long time.



I took it to my regular garage and it won't connect to their diagnostics machine. I think it's the 2.0 HDI non turbo engine but here's a picture of the engine bay View attachment 53889



Any ideas on what the problem could be?


What car is it ?


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
1,904 Posts
There you go KyleRiffs lots of good info to get you started and a couple of members you could give a PM message to and ask if they will drop by and give it the once over. That is if they have enough room in their "in" box. If full it will not accept anymore until the member empties out some old messages as I found when I first joined! Hence why I bit the bullet and bought the discs etc.
 

·
Registered
Joined
·
14,581 Posts
You need to check all the little vacuum hoses.
I had the same problem with mine. It is the RHS engine, slightly different from yours. But one of the hoses had a little tear, of course it was the one, that were hardest to get to.
90 hp engines dont have all the solenoids a 110 has its a totally different system this is 1 of the problems with the man down the pub syndrome im on about.

EVERY version of the 2 litre has different control systems the 90 has no vacuum other than the EGR the boost is old school wastegate with boost control NOT vacuum control.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #13
Sorry for the lack of reply, I gave up on the car and it's been sitting for months. I had a mobile mechanic out today and he seems to think it's an electrical problem or mass airflow. After restarting the system the power has come back but not how I remember it being
 
1 - 14 of 14 Posts
Top