Peugeot Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Morning all,
Looking for some info / help for my 406.
Bit of background, had car from new, Nov 2000. Very well maintained and not messed with, all wiring and under bonnet original. No problems apart from a fuel pump in 2005. Passed all MOT's 1st time, Last MOT Monday 26th Sept.

Got a problem, car starts and runs, pulls well.
Try to accelerate from 40 ish hard, engine stops as if it's been switched off, EML comes on. Stop for 20 secs can start engine, drives fine but with EML on.

I've only got a OBD plug in cheapo, but it come up with P0230 fault.
Any ideas or suggestions appreciated.
 

·
Registered
Joined
·
4,782 Posts
Morning all,
Looking for some info / help for my 406.
Bit of background, had car from new, Nov 2000. Very well maintained and not messed with, all wiring and under bonnet original. No problems apart from a fuel pump in 2005. Passed all MOT's 1st time, Last MOT Monday 26th Sept.

Got a problem, car starts and runs, pulls well.
Try to accelerate from 40 ish hard, engine stops as if it's been switched off, EML comes on. Stop for 20 secs can start engine, drives fine but with EML on.

I've only got a OBD plug in cheapo, but it come up with P0230 fault.
Any ideas or suggestions appreciated.
You need to get it on planet/diagbox to read the codes and have a look at live data have a good read here it explains how to contact a member http://www.peugeotforums.com/forums/introductions-28/brief-faq-guide-new-members-83170/
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Thanks for your reply, I'll have a look.

Just a bit more info, as per the original thread, had this from new, great car. Only at 112000 miles. Dont want to trash it just jet.
Just gave it a run, as I say runs perfect, just wont rev over 2500 / 2700 rpm.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Message for Risk30uk

Hi Mate,
Am looking for a diagnostic check for my406 Hdi,am in Aylesford, Kent
Got a fault causing rev limit to 2500/ 2700 P0230 code read from my cheapo obd plugin.
Had the car from new, 112000 miles, not a donkey.
Will pay the going rate / beer tokens etc.
Thanks

Could'nt send a message, your inbox is full.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Hi Graham,

Filters change and service last Friday, 23rd Sept.
By the way thanks for you help re the key
 

·
Moderator
Joined
·
6,277 Posts
I would look at removing the fuel pressure regulator on back of pump and check o-rings and that it clean.

If it has a in tank pump that would be my second check.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
Thanks for the reply,
Already removed and checked / cleaned regulator from end of HP pump.
Tank pump runs and pumps fuel up to filter OK.

Got me scratching my head, am a retired HGV mech, not got the Peugeot diag tool, just a cheapo OBD plug in, reads P0230.

Keep em coming, thanks again.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
Thank you for the replies,
Pulled it apart today, tank pump pumping, took fuel filter and housing off and checked (filter fitted last week).
Took sensor off rail, blew it out, might get another anyway.
Replaced the relay next to the ECU as I got given a new one.

Put it all back, switched on and off 3 times to prime filter housing, fired up as per normal,runs sweet.
EML still on though.

Trying to get in touch with a Planet user near me according to the map on here, cant message him as his inbox is full, popular fella.
Anyway I'll keep plodding along.
 

·
Registered
Joined
·
1,805 Posts
If the fault has been fixed, the car might need a couple of drives before it will clear the code and reset the EML. But that's only if the cause of the problem has been fixed, and there aren't any other faults logging as permanent on the engine ECU
 

·
Registered
Joined
·
15 Posts
Discussion Starter #13
If the fault has been fixed, the car might need a couple of drives before it will clear the code and reset the EML. But that's only if the cause of the problem has been fixed, and there aren't any other faults logging as permanent on the engine ECU
As I said, am trying to contact a Planet user
 

·
Moderator
Joined
·
6,277 Posts
As above three/five "Journeys" (ie from cold to normal operating temp) dependant on fault. If the fault does not reoccur the engine light will reset without planet,

If you can read codes with generic reader you should be able to clear them with the same tool if it has that function
 
1 - 14 of 14 Posts
Top