Peugeot Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi chaps did anyone find a fix for this , some say it was rare to have abs but it defo has .
Warning light comes on as soon as car starts so failed it’s MOT.
Really keen to find a mechanic that knows how to fault find in essex as everyone now seems to want to just plug in a get fault codes .
I get these are getting old but surely can be remedied.
Have heard BBa reman can poss rebuild the abs pump but really need to be positive it is the pump like I been told .
I’m seriously no mechanic so not something I would have any idea about .
Any help would be very much appreciated as just want her to work properly!
 

· Registered
Joined
·
1,142 Posts
A 205GTi with ABS is rare, I bet it has a cat` as well, the last of them had everything.. What you need is an old school Peugeot specialist with an equally old school Peugeot diag` tool. I used to work on these in their day but I`m long retired, and I gave my old Peugeot diag` kit away 😥!! My old Peugeot mate would be able to fix your problem but it will mean a drive to Berkshire. I Googled Essex and came up with this guy, Peugeot, Citroen Servicing and Repairs Specialist. May be worth a try ? I bet its a damaged wheel sensor, highly unlikely to be the ABS unit. Has any work been done recently ? like changing a driveshaft or a rear drum/hub. If my memory is correct there is a ABS ring on a driveshaft and a rear hub. A car of that age it could even be just a poor multiplug or a "green" wire.
 

· Registered
Joined
·
1 Posts
Hi, I don’t know where you got to with this but I can fix this for you. I have a 205 with ABS and have the original Peugeot fault reader and have developed a lot of test jigs and a lot of understanding of the system. Drop me a message if you like. Rob
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top