Peugeot Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1 (Edited)
My car cut out for no reason and my pp2000 gave me this code, along with cant connect to the engine ecu??????????????
I cant remember the exact wording but it was something like, +ve power loss from power control unit to engine ecu?????????? does anyone know where it is? and how do I test this fault?
Is it a common fault?
Has anyone had/sorted this fault before?
Two weeks ago I had the MAF replaced, along with the Fuel Filler pipe/cap sensor, Full service, brakes all done, gearbox oil changed, engine oil and filtre replaced, fuel filtre replaced, air filtre replaced, all for a long journey up North, done nearly 400miles not a miss fire, cough, nothing, then on my way home from work it cut out in the middle of the road, rush hour, no warning? and wont start ever since?
Its never ending these faults no matter how well I look after it? ive never had a car so unreliable in my life!!!
I ended up buying a laptop and pp2000 kit to save being robbed by peugeot, but it still costs a fortune every time I use it?

2003, mint condition, 2.2hdi exec, 63000 mls on the clock heading for the scrap yard at this rate, I wont even sell it as I wouldn't inflict this car on anyone.
Hi all, again. Still no joy starting this 807 of mine removed all fuses checked them twice, all good, all connections good on the fuse boxes? Turns over, won't start? Pp2000 says can't communicate with engine ecu? So I removed the pollen filter ( didn't know I could do that?) and found this picture 1. Abig thick wire with a burst out bolt on it from a big relay ( picture 2)? So got another relay fitted it and still no joy? But this relay has power supplied to it no matter which fuse you remove? Power only gets removed when you disconnect the battery? Has this burnt out the Loom???

Now ive found the power supply lead to the glow plugs runs direct to earth ( shorted glow plug ) tested at the engine connection at the side of the cyl head.

now having ripped the car apart I have noticed that the engine management light on the dash dosent come on at all now? where does that get supplied from?
 

Attachments

·
Registered
Joined
·
1,054 Posts
Hope you get it fixed, how about re-doing the earths on the chassis legs? Try wiggling the loom as someone tries to start it especially when the loom extends from rear left of engine and top of gearbox to body. 2003 807 GLX 220K
 

·
Registered
Joined
·
33 Posts
Discussion Starter #6 (Edited)
If only my friends were interested enough to help me? ha.
I see you have had experience with this, Its such a shame as my car doesnt do more than 4, or 4 and half thousand miles a Year? its such a stupid intermitant fault on a well kept car, and its almost impossible to find the fault?
 

·
Registered
Joined
·
14,895 Posts
control unit 1320 is the engine ecu i believe you need to go back into planet and go through the BSI checking for comms to engine ecu and whether its unlocked planet can do lots more than just code read.

I would also check the fuses next to battery inside the car as to be honest it sounds like a power issue.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #8
Thanks, Im going to test the battery compartment fuses tonight, I removed and tested all the fuses in the engine compart fuse box last night.
It wasnt until I removed the entire fuse box that I found 8 of those big fuses? as I could only ever see 4! I tested the lot and the relay in there as well, everyone of them were good. also tested the three relays ( two green one blue ) in the wee box above the radiator, all good too.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #10
control unit 1320 is the engine ecu i believe you need to go back into planet and go through the BSI checking for comms to engine ecu and whether its unlocked planet can do lots more than just code read.

I would also check the fuses next to battery inside the car as to be honest it sounds like a power issue.
Thanks reliable406, checked the battery compartment fuse box tonight, totally clean,dry,tight, all fuses/wires in good condition.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #11
Some Lexia hardware with Planet can't read the engine ECU. My 307 is the same. You need revision C with Diagbox 7.
Thanks Gibbo, will check the version when I unclench my fingers again, Ive no idea what version I have at the moment? but it did/has worked no bother before?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #14 (Edited)
control unit 1320 is the engine ecu i believe you need to go back into planet and go through the BSI checking for comms to engine ecu and whether its unlocked planet can do lots more than just code read.

I would also check the fuses next to battery inside the car as to be honest it sounds like a power issue.
Done all that, the bsi cant communicate with the engine ecu? and cant communicate with the air conditioning ecu either? all the fuses are good, clean, dry and tight, all connections at battery are good,dry,clean and tight.
Im moving on to the fuse box above the throttle pedal now. I dont know where the engine ecu is or what the control unit is/where it is? so im going at it blind testing all the wiring connections at the mo and the rest of the fuses. eveywhere I look in my car is dry clean and in very good condition? its very annoying as its definately a loose wire/broken wire somewhere?
Thanks for your help reliable406.
 
1 - 15 of 15 Posts
Top