Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I had a complete new clutch fitted on my 1007. After 5 days, and approx 300 miles, I now have a vibration through the foot pedal. This can be felt if the foot is placed gently on the pedal, and also when changing gear. Any ideas? I have been told that this could be a lubricant which may have leaked onto the clutch itself, or that 2 nuts with a split pin haven't been tightened corectly? All gobbledygook to me. The garage where it was fitted reckon they can't even feel a vibration, but it is very clear to me. I would appreciate some ideas which I can throw back at them! :confused:
 
C

·
Guest
Joined
·
0 Posts
Either the clutch is faulty, was damaged as the installed it, or it wasn't centred properly.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks Chopper, your info was very helpful. The garage have finally agreed to replace the complete clutch.
 
D

·
Guest
Joined
·
0 Posts
Sounds like a rubbish pressure plate. Make sure they put in a good guality clutch kit ie LUK or VALEO.
 

·
Registered
Joined
·
67 Posts
It can be thrust/release bearing,clutch plate springs and or some of the friction plate came of,pressure plate fingers uneven, not installed absolutely straight when they did it and damaged the clutch kit,there is a lot of things that it can be, I will only be able to say for sure if I test it myself in person, for instance is it when you depressed the pedal or resting your foot slightly on it before depression, if it is before depression and is ever so slightly and no noise is heard from engine compartment it might not be of concern but needs to be checked out as parts needs to work in still
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Thanks for the info. All duly noted in case we get any more grief. Fingers crossed it gets sorted soon!
 
1 - 8 of 8 Posts
Top