Peugeot Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
My Sons are om a trip and they have problems with engine losing power, no throttle response, and if they put in in neutral just rolling thers no servofunctions on brakes and steering, which is a little critical. So they pull over and stop engine and when they start on again all is fine, for a while. This have happend a number og times on this trip. Any ideas?
 

·
Registered
Joined
·
10 Posts
Hey if the engine is running you should have steering and brake servo function....Two separate pumps can't fail and start working again after a restart....Is the engine stalling?

On my -08 the pumps are mechanical driven..maybe on
newer models they are electric?

The powerloss can be clogged dpf or that the ECU thinks it's clogged....Mine had no throttle respons intermittent..But connected my computer and told the ECU that new dpf was fitted( after i checked the sot % in dpf first) And now it runs just fine.....I had of course engine light flashing and warning message for risk of clogged dpf....Maybe someone else have some other thoughts about this.....
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks for replay. The dpf on this car have been removed, and a tuningcompany have programmed it and the egr out. But the enginelamp did show up and another faultcode appeard, asr/esp. I’m not sure if the powersteering is electric or hydraulic or how the power asissted brakes get the servopower, vakum or what. I’ll check when they return from the trip tomorrow. Can there be a problem with glowplugs og the relay for this?
 

·
Registered
Joined
·
10 Posts
Thanks for replay. The dpf on this car have been removed, and a tuningcompany have programmed it and the egr out. But the enginelamp did show up and another faultcode appeard, asr/esp. I’m not sure if the powersteering is electric or hydraulic or how the power asissted brakes get the servopower, vakum or what. I’ll check when they return from the trip tomorrow. Can there be a problem with glowplugs og the relay for this?
The glowplugs only helps with cold starts below zero and they also helps with dpf regeneration so i don't think that's the problem....On my 407 SW -08 1,6 hdi the vacuum pump for the brakes are driven by one of the camshafts and servo steering pump by the multi belt in front of the engine...But i know some have electric steering pump...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Just taked to my son again, They are on their way home, but the car continues to stop. I misunderstood what he ment when he said that there was no throttle response. What is happening is that the engine stops, or cut out, so then its no wolnder he have no power to the steering and brakes, unless its in gear, caus then the gear keeps the engine turning.
Anyway what can cause the engine to just cut out while driving? They pull over and start the car again and then all is fine, for some minutes before it stops again.
 

·
Registered
Joined
·
10 Posts
Fuel problem is my guess...Change fuel filter and check for fault codes... would be my first thing to do.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Yes could be, but I changed the fulefilter short time ago. They went by a tuningcompany yesterday and read the codes, fuelrailsensor! So I have to have a look at that now!
A mecanic here also said it could be the crankshaftsensor!
 

·
Moderator
Joined
·
9,199 Posts
Fuel rail sensor fault is very rare more often its a bad injector or regulator on the HP pump
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Connected my reader, gets codes P0193 og P1166 but the reader says cannot find theese codes in the database but on the net I find that they are related to fuelrail pressure. So that would be the next job on this car, but to get to it is a bit of a hassle, at the rear of engine under the egr valve.
 

·
Moderator
Joined
·
9,199 Posts
Disconnect the electrical plug to egr (it will put light on but still drive normally).

if the cutting out stops your egr is faulty they can fail and short the power rail to the egr which also feeds fuel rail sensor

The codes are for high fuel pressure and regulation. If not egr it will pump regulator or wiring fault most likely

Sent from my SM-T830 using Tapatalk
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
Ok, thanks, we did have the car at a tuning service and they programmed the egr and the dpf out. This was done half way on the trip my sons had last week. (the dpf had been removed previously by the last owner of the car)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
So when I got the car back here after the trip, there was no cooling liquid in the expansion tank, the hose under the airfilter had a small hole in it, caused by the airfilter not fixed in its place properly, I was thinking this could have caused the problems above? But no, the engine still stops, and I have actually now sold the car but have taken it back to sort this issue out. The new owner of the car was driving and she said that when she puts the gear in 3. then the engine stops, now I have to take a trip my self to see if this stopping issue will happend to me, and see if the dashboard lights will stay on or not when the engine stops, if they go out then it may be an electrical error or bad connection somewhere.
 

·
Registered
Joined
·
1 Posts
Just taked to my son again, They are on their way home, but the car continues to stop. I misunderstood what he ment when he said that there was no throttle response. What is happening is that the engine stops, or cut out, so then its no wolnder he have no power to the steering and brakes, unless its in gear, caus then the gear keeps the engine turning.
Anyway what can cause the engine to just cut out while driving? They pull over and start the car again and then all is fine, for some minutes before it stops again.
My 207 had temp sensor that guage was normal but told ecu that it was over heating , ran 25 K and shut down. Replaced sensor. Then ok.
 
1 - 14 of 14 Posts
Top